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Section One 

Introduction to MS Project 

After completing this section you will be able to: 

• Start MS Project. 

• Open a Project File. 

• Change the View of a Project. 

• Use the Toolbars and Menus. 
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What is Microsoft Project? 

MS Project is a tool to help you to plan projects, manage and update project information, 
and communicate the status once the project is under way.  
 
The details of the project tasks and associated resources are entered into the system as a 
new project.  The system will then display the data in such a way that the relationships of 
the tasks and their time scales can clearly be seen and potential problem areas identified.  
 
Project data can be entered and/or viewed in a number of ways; the three principal formats 
are charts, forms, and sheets. 
 
Charts can be either Gantt Charts or Network Diagram Charts both of which are a 
diagrammatic representation of the project data. 
 

Gantt chart 

Network Diagram 
Chart views: 

Resource Graph 
 
Forms contain the data relevant to a single specific task or resource. 
 

Task form Form views: 
Resource form 

 
Sheets are a table of all the Tasks or all the Resources that are part of the Project. 
 

Task sheet Sheet views: 
Resource sheet 

 
The above can be displayed separately or in any combination of two e.g. 
 

Combination view: Task Entry View 

 Top half Gantt chart 

 Bottom half Task form 
 
You can combine any two single-pane views on the screen to create a combination view. In 
a combination view, the information in the bottom relates only to the task or resources in the 
top view. The reason for having combination views is to make the job of entering and 
analysing information easier. 
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Understanding Project Management 

At the heart of every project management system is a scheduling algorithm. An algorithm is 
a mathematical or logical equation that solves a complex problem by breaking down the 
problem into simple steps. When scheduling resources and parameters are entered into it, 
the scheduling algorithm produces a project schedule that would be impossible for you to 
produce manually. This Input/Output model is displayed below. 
 

The “Black Box”
(algorithm)

Input

Task Information
Task Name
Duration
Task Relationships
Fixed Costs
Constraints

Resource
Information
Who
Availability
Cost

Output
(Schedule)

Gantt
PERT
Resource Graph

 
 

The Input/Output Model 

 
 
In Microsoft Project, however complex your project may be, you can vary only information 
regarding tasks or resources. The information you provide is fed into the “Black Box” or 
algorithm, to provide you with a schedule in the form of a Gantt chart, Network Diagram 
Chart, or Resource Graph. In summary, the seven or eight parameters that you enter result in 
output that is a schedule displayed on various views and forms. 
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MS Project Language 

The project management industry uses specific language and terminology. Some of these 
terms are illustrated below. 
 
 

Summary Task

EA   The earliest possible time a task can start.
SS   The scheduled start time of the task.
SE   The scheduled end time of the task.
LE   The latest possible time a task can end.

Predecessor Task

Task A

Task B

Successor Task

EA           SS                                    SE              LE

Total SlackDelay

Free Slack

 
Above: Clarification of Terms 

 
In the illustration above, two tasks have a relationship. Task A is the predecessor task, and 
Task B is the successor task. Both of these tasks are considered to be non-critical because 
they both have flexibility. Let’s focus on Task A. EA marks the earliest possible time Task 
A can start. SS marks the scheduled start time for Task A. By default, all tasks are scheduled 
to start at the earliest possible time, unless you specify otherwise. In the example above, 
Task A is scheduled to start later and therefore has been delayed. SE marks the scheduled 
end time for Task A, and LE marks the latest possible time Task A can end. Both of these 
tasks have slack, the amount of time a task can slip before it affects another task’s dates or 
the project finish date. Free slack is the amount of time Task A can be delayed before 
affecting the start time of Task B, and total slack is the amount of time that Task A can be 
delayed before affecting the finish date of the project. The summary task summarizes Tasks 
A and B. 
 
Critical tasks, not shown above, have no slack; therefore, delaying this type of task would 
mean delaying the project. A critical path is a series of critical tasks. All tasks on a critical 
path must be completed on time for the project to finish on time. If one task on a critical 
path is delayed, then the project is delayed. In Microsoft Project, a critical path is shown on 
the Gantt chart and the Network Diagram Chart in red. 
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Terminology 

Actual Usage A measure of the resource expended in completing or 
partially completing a task. 

ALAP Refers to a task that should be started ‘As Late As 
Possible’, using all the free-float time available. 

ASAP Used to indicate a task that should be started ‘As Soon 
As Possible’, taking into account the start date of the 
project and its predecessor tasks. 

Baseline The original project plan, including the time schedule 
and resource and cost allocations.  The baseline is 
used for comparing projected values to actuals, and 
facilitates the tracking and analysing of a project’s 
progress. 

Cost Variance A project tracking function recording the difference 
between the budgeted cost of the work performed and 
the actual cost.  Values below the baseline show an 
overspend and positive values denote cost savings. 

Critical Path The sequence of tasks or activities whose schedules 
and durations directly affect the date of overall project 
completion. 

Earned Value This is a measure of a project’s performance, and is 
calculated by multiplying a task’s planned cost by the 
percentage of work completed. 

Float (slack) The amount of time by which a non-critical task can be 
delayed before it affects another task’s schedule. 

Gantt chart A graphical representation of a project schedule 
showing each task as a bar, the length of which is 
proportional to its duration.  Many project management 
packages use a spreadsheet section to the left of the 
Gantt chart to display additional information. 

Hammock Task A task whose duration is calculated based on the time 
span between its predecessor and successor 
activities. 

Histogram A bar chart that shows resource workloads over a time 
period. 

Lag The amount of time between the finish of a 
predecessor task and the start of a successor task. 

Lead The amount of time that a task is permitted to start 
before its predecessor is finished. 
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Terminology (cont.) 
 

Loading A measurement of resource usage on a task per unit 
of time.  Different methods of loading may be used 
depending on what’s available in your project 
management application and what’s applicable for 
your particular project. 

Loading(back) A loading pattern that allocates resource usage as 
late in the task as possible. 

Loading 
(contour) 

The contour-loading pattern assesses which 
resources are left over after allocation to the critical 
tasks and spreads these resources among the 
remainder. 

Loading(fixed) When using fixed-loading algorithms, you specify the 
actual amount of resource allocated to the 
encompassing tasks. 

Loading(front) Front loading systems will attempt to allocate 
resources as early in the task as possible. 

Loading(uniform) This loading pattern allocates the resource usage on 
a by day basis in a task.  This will usually be done 
without causing any one task to be over committed. 

Milestone A project event that represents a checkpoint, a major 
accomplishment or a measurable goal. 

Negative float Refers to an unscheduled delay before an actual 
task start time that must be recovered if the project is 
not to be delayed. 

OBS codes Organisational Breakdown Structure codes are used 
to identify tasks by resource groups in a hierarchical 
format.  OBS codes are often used to reflect 
departmental structure in a company or code of 
accounts, and can also be used for filtering tasks. 

Network Diagram Project Evaluation and Resource Tracking charts, 
also called network diagrams.  Network Diagrams 
are a graphical depiction of task dependencies, and 
resemble flow charts.  Dependencies are shown by 
connecting lines or arrows indicating the work flow. 

Predecessor In dependency relationships, the predecessor is the 
task that must be started or completed first. 

Project 
Management 

Best defined as a body of knowledge, a set of 
principles, or techniques dealing with the planning 
and control of projects. 

Resource Any person, group of people, item or equipment, 
service or material used in accomplishing a project 
task. 
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Terminology (cont.) 
 

Resource 
Levelling 

The process of resolving resource conflicts.  Most 
project management programs offer an automated 
resource levelling routine that delays tasks until the 
resources assigned to them are available. 

Resource Driven Task durations determined by the program and 
based on the number of an allocation of resources, 
rather than the time available.  Both individual tasks 
and entire projects can be resource-driven. 

Sub-project A group of activities which are treated as a single 
task in a master project schedule.  Subprojects are a 
way of working with multiple projects that keep all 
the data in one file rather than in independent files. 

Successor In a dependency relationship between two tasks, the 
successor is the task that must await the start or 
completion of the other. 

WBS codes Work Breakdown Structure codes are used to 
identify tasks in a hierarchy.  Many project 
management applications associate these codes 
with an outline structure.  WBS codes can be used to 
filter the project schedule for tracking and reporting 
purposes. 
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Starting MS Project 

 Start MS Project 
• Double-click on the MS Project icon. 

 Or 

• Click the Start button, select Programs, select the Project icon. 

 Using Help 
• Click on the Help menu and select Microsoft Project Help or press 

[F1]. 

• The Project Help task pane will open on the right of the screen enabling 
you to search for assistance on a specific topic. 

 

The Office Assistant 

The office assistant offers tips on what you are doing, can answer questions you have, and 
enables you to ask questions in a non-jargon way.  The office assistant usually appears as an 
animated paper clip. 
 

 To Use the Office Assistant 
 

• Click on the Help menu and select Show the Office Assistant 

Screen shot 
• Type in the topic required. 

• Click on Search 

 
Note:  When performing certain actions (especially for the first time) the 
Office Assistant will appear automatically with a list of help options relative 
to what you are doing. 
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As well as offering help, the Office Assistant also offers tips on quick or short cuts for the 
features you are using.  If the Office Assistant is visible a light bulb appears next to the 
paper clip.  Otherwise a light bulb appears on the tool on the toolbar. 
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MS Project - The Screen 
 

 
 

 

 
The Menus: Always displayed, some options depend on the selected view. 

Tool Bars: Buttons provide quick access to the most common commands, 
The bars can be customised 

Task Pane With options to help when ‘Getting Started’. Other task panes are 
available. 

Entry Bar: The entry point for text with outlining buttons. 

Status Bar: At the bottom of the screen showing the current status. 

Scroll Bars: When using a mouse to scroll the views and to move the 
boundary between two views.  

Working Area: The area for 1 or 2 views, the size of each can be adjusted. 
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Elements of the Default View 

The default Project view is the Gantt Chart view, as displayed below. This view is used 
extensively in Microsoft Project. The Gantt Chart consists of a Gantt table and a Gantt bar 
chart. The divider bar separates the two and can be repositioned to display more of the table 
or more of the chart. The Gantt table consists of rows and columns. Just like on a 
spreadsheet, the intersection of a row and a column is called a cell. The Gantt bar chart 
graphically displays your schedule on a time line. 
 
The status bar displays the current mode of operation and warning messages and indicates 
when special key control modes, such as Num Lock mode, are on. The entry bar contains an 
Entry box where all information is input. The default toolbars are the Standard toolbar, 
Formatting toolbar and the Project Guide. Other toolbars can be displayed by choosing 
Toolbars from the View menu. 
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Views and Tables 

A view is the format of the way that project data is displayed on the screen and there are a 
considerable number of different permutations that can be used. 
 
The View Menu is the first place where the view that is required is selected. The basic 
selection is between a Chart, a Form, or a Sheet.  Some of the options in this menu can 
provide a split view to show two different displays for the same Task or Resource. 
 
You can also use the View bar, located vertically on the left of the default view (if it is 
active). To activate/deactivate the View Bar, select View, View Bar. 
 
As well as the standard views achieved with the View menu or View bar, you can select 
More Views to see more detailed and complex views and forms. 
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The table below describes some of the main views in Project. 
 
Calendar: Shows the view in the form of a calendar. 

Gantt Chart: A diagrammatic view of the Tasks and their time scale.  This 
chart can also show the relationship between Tasks and the 
Critical Path.  It usually shows the task entry form alongside 
the Gantt chart. 

Network Diagram 
Chart: 

 Network Diagram is an acronym for Programme Evaluation 
Review Technique.  This view represents each Task as a 
box with relevant information within it.  The layout of the 
boxes on the chart and the lines that link the boxes 
represent the structure of the project. 

Task Usage: The Task Usage view displays project tasks with their 
assigned resources grouped underneath them. 

Tracking Gantt: The Tracking Gantt view displays two task bars, one on top 
of the other, for each task. The lower bar shows baseline 
start and finish dates, and the upper bar shows scheduled 
start and finish dates (or if the task has already started, 
meaning that the percentage complete is greater than zero, 
the upper bar shows the actual start and finish dates). 

Resource Graph:  A graphical representation of a single resource and its 
utilisation. 

Resource Sheet:  A list of all the resources for the project. 

Resource Usage:  This is a view that shows the use in hours per day for each 
resource. 

More Views: Allows the showing of combination views as well as details 
of a single Task 

Table:(Entry): Changes the form alongside the Gantt chart. 

Reports: Takes you into Report Wizard. 

Toolbars: Allows you to change the Toolbar display. 

View Bar: Activates the View bar, located vertically on the left of the 
screen. 

Zoom: Changes the amount of information you can see on screen, 
from days to years. 
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The Tracking Gantt View 

When you initially set up your project with tasks and dates, and then save the project with a 
baseline, the Tracking Gantt view displays those tasks as shown in the following example. 
 

 

 
 
The baseline bars and the scheduled or actual bars are synchronized. However, if the start 
date of task slips by, say, 2 days, the red scheduled bar will extend 2 days beyond the lower 
baseline bar. 
 
Because the tasks are linked, the slipping of task 2 will cause a ripple effect, making its 
successor tasks slip by 2 days as well. 
 

You can use the Tracking Gantt view to: 
 

• See how tasks progress across time and evaluate the slippage of tasks. 
You can track progress by comparing baseline and scheduled or actual 
start and finish dates and by checking the completion percentage of 
each task. 

• View tasks graphically while still having access to detailed information 
about the tasks. 

• Create a project by entering tasks and the amount of time each task will 
take. 

• Establish sequential dependencies between tasks by linking them. 
When you link tasks, you can see how a change in the duration of one 
task affects the start and finish dates of other tasks and the project finish 
date. 

• Assign personnel and other resources to tasks.  
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MS Project - Menus 

The File Menu 
The File menu is typical of the windows environment. The command which pertains to MS 
Project is: 
 
 Properties: Provides basic information on the Project. 

The Edit Menu 
The Edit menu is also typical of the windows environment. Commands which pertain to MS 
Project include: 
 
 Link Tasks: Create links between tasks. 
 Unlink Tasks: Break an existing link. 
 Go To: Go to a task or resource. (Depends on view.) 

The Insert Menu 
Among other things allows you to insert new rows for tasks or columns for information. 
You can also go to the Task information dialog box to add more detailed information to the 
current task. 

The Format Menu 
This changes dramatically when different views are selected. The following are the principal 
selections. 
 

For a Network Diagram the choices are: 
Text Styles: Modifies the size, and type of the selected text. 
Box Styles: Changes the appearance of the Network Diagram boxes. 
Layout: Allows you to customise the way links are shown. 
Layout Now: Redraws to show changes made to links etc. 

For the GANTT chart the choices are: 
Font: Used to change the font. 
Bar: Change the selected Gantt Bar style 
Timescale: Allows you to set the displayed time at anything from years to 

minutes. 
Gridlines: Allows you to display or hide Gridlines and change their 

appearance. 
Gantt Chart Wizard: Takes you through the programs method of setting up your 

Gantt chart. 
Text Styles: Change the font, size and colours 
Bar Styles: Change all Gantt bars. 
Details: Details of the Gantt chart 
Layout: Change the way the bars are displayed including links. 
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The Tools Menu 
The main choices here are Change Working Time, Tracking and Multiple Projects. 

 Assign Resources: Apply various filters to the tasks. 
 Level Resources: Shows resource levelling information 
 Change Working Time: Format a new Calendar. 
 Tracking: Check the progress. 
 Links Between Projects: Set up sub projects and links. 

The Project Menu 
This menu is for retrieving information on the project and its components. Some of the 
options launch sub menus. The commands are fairly self-explanatory and will become 
clearer later in this course. 

There are also the usual Window and Help options. 
 
You will find that the menu choices may change depending on the view selected. If this 
happens it simply means that the option you wanted is not available for that view. 



  Microsoft Project 2003 
  Introduction to MS Project 
   

 Page 25 © The Mouse Training Company 
   

MS Project - The Tool Bars 

The Buttons provide quick access to some of the commands available from the pull down 
menus.  The default arrangement of the toolbars is the Standard and Formatting bars active. 
 
The formatting bar is virtually identical to the same thing in other Office applications, 
except it has the Outline tools attached to it. These tools are for promoting and demoting 
tasks, Collapsing and expanding sub tasks plus the usual Text format and alignment buttons. 
 

 
 
The Standard toolbar contains the following buttons: 
 

 Create a New blank file.  Link the selected tasks with a 
Finish-to-Start relationship 

 Open an existing File.  Unlink the selected tasks. 

 Save the current file  Split the selected tasks 

 Print the active View  Open the Task Information 
dialog box. 

 Print Preview the active view  Attach a note to the current task. 

 Spell-check the selection.  Task drivers 

 Cut the highlighted section to 
the Clipboard  Add Resources. 

 Copy the highlighted section 
to the Clipboard  

Group Information. 

 Paste from the Clipboard.  Zoom in. 

 Format Painter.  Zoom out. 

 Undo the previous action.  Go to selected task. 

 Redo the previous action  Copy a static Picture so it can be 
used in another application. 

 Insert a hyperlink Launch the 
Web toolbar.  Display the Office Assistant 
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 Loading and Viewing a Project 
• Select File, Open to open any project file. 

• Press [Ctrl-Home] and [Alt-Home] to go to the start of the project. 

• Use the scroll tools to see the project progress. 

• Use the mouse to change the size of the various windows. 

• Alter the time scale with View, Zoom. 

 Change the View 
• Click on the View menu.  

• Choose each of the top five and note the different screens. 

• Select View, Gantt Chart to return to the original view. 

• Move the mouse to the central vertical bar on the screen when it will 
change to a double line with a double-headed arrow 

• Click and hold the left button and drag left to see more of the Gantt 
Chart. 

• Repeat but drag right to see more of the Entry Table. 

 Change the Project Start Date 
• Select Project, Project Information from the menus. 

• Change the project Start Date. 
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• Click OK and examine the views again. 

• Select Tools, Tracking, Update Project to see project progress so far. 

 

 Exit Project 
• Select File, Close to close the existing project file. 

Note: PLEASE DO NOT SAVE ANY CHANGES! 
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Project Management 

Project: - ‘A planned undertaking’ 
 
The skills of project management are gathered from a wide range of experiences. 
Consciously or sub consciously we all apply these skills in the daily administration of our 
work.  
 
Where a major undertaking has to be completed, these skills are not only brought into focus 
but must be applied in a much more structured format. 
 
We must take on the jargon and techniques of the Project Manager as well as become 
familiar with the "Tools of the trade".  
 
To review the skills that are relevant to project management 
 

• The ability to define the Goal, Objective, Specifications and 
Limitations of a project. 

• The ability to define the individual tasks in sufficient detail and 
sequence to meet the objective with the minimum of problems, and 
within the defined time scale. 

Task attributes should include some or all of the following 
 

• Objectives 

• Time constraints 

• Milestones 

• Task(s) on which this Task is Dependant 

• Estimated Duration: - 

• Task(s) that are dependent on this task 

• (Optimistic estimate) 

• Itemised task Budget 

• (Pessimistic estimate) 

• Resources required to complete the Task. 

• The ability to manage the progression of the tasks in terms of their 
resources, start times and finish times. 
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• The production of appropriate progress reports. 

As the complexities of these undertakings increase so the importance of discipline and 
structure increase and the Project Manager must look to the tools that can help which is 
where Microsoft Project comes into the picture. 
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The Stages of Project Management 

The process of project management is divided into specific stages which can be defined as 
follows: - 

Define the Project 
| 

Plan the project 
| 

Implementation 
| 

Monitoring and Adjusting 
| 

Evaluation 

Defining the Project. 
Setting out the Goal and the Objectives together with the Specification and Limitations 
within which the undertaking must be completed. 

Plan the Project 
Planning of all the activities, resources, and estimation of materials and time scales. Some of 
this planning may have to be done at an appropriate level for cost estimation before the 
project can be agreed.  Once the decision to go ahead has been taken the skills of the Project 
Manager are used to define the details of the planning stage.  When this has been completed 
and agreed it will become the "Plan" or the base line against which progress can be 
measured. 

Implementation 
A leap into the void! 
 
Notes: A poorly planned project will take three times longer that the original plan. A 

well-planned project will only take twice as long. 
 

 A project that will be completed without changes, on time and within budget 
has never been known in the past and will never happen in the future. 
 

 Microsoft Project will help! 
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Monitoring and Adjusting 

Recording Actual Progress 
Once the project is under way, the progress of each activity is recorded. This information 
can then be compared against the Plan and the differences highlighted.  

Revising the Schedule 
The process of minimising the effect of problems and delays on meeting project deadlines is 
achieved by adjusting and updating the Schedule to meet the changed circumstances. 

Evaluation. 
As the project progresses and when it has been completed the process of evaluation should 
be used to learn the lessons for the next time. 
 

MS Project - Operational Basics 

MS Project has the following capabilities: 
* 1 million tasks per project (depending on free RAM) 

* 1 million resources per project 

* Calendar dates from 1984 to 2049 

Highlights 
* Gantt charts to show project schedules graphically on a time scale (with 

scaling from minutes to years). 

* Network Diagrams to show task relationships. 

* Outlining to group and arrange project tasks in hierarchical order. 

* Filters to view selected information. 

* Resource usage and Graph views and reports to quickly identify resource 
availability and costs. 

* Split views to see any two screens simultaneously. 

* Custom fields so you can track additional information unique to your project. 
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Section Two 

Planning the Project 

After completing this section you will be able to: 

π Design a sample project. 

π Begin to use Microsoft Project. 

π Create a Project File. 
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Defining the Project 

This is the starting point for a new project. The following are the areas that must be 
completed: 

The Goal 

This is a short statement of what the project should achieve in the broadest terms. For 
example if the project is to build a new road to divert traffic away from a shopping centre 
the goal would be: - 
 

To make access to the shopping centre easier for pedestrians and improve the 
shopping amenities for local residents. 

 

The Objectives 

The objectives can be more specific and there can be any number of them as required.  To 
continue the example from above the following are examples: - 

 
• To build a road for through traffic that does not use any existing 

residential areas. 

• To design the road and the route to allow for the projected traffic 
flow for the next 20 years. 

 

The Specification 

This section will provide more detailed areas for the project, for example it may specify 
the broad sections of the project and at what points approvals are required before 
proceeding.  There may be a section concerning where resources should come from.  It 
may also specify the management team. 

 

The Limitations 

These are the restrictions that will affect the project, for example there may be a cost 
limit, there could be a set of regulations that must be adhered to, time may be a vital 
factor. 
 
When these areas are clearly specified before the project starts there is a much greater 
chance of the project succeeding and major pitfalls being avoided. (In theory!)
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Complete the Project Definition 
 
As an exercise, define a project that can be planned in the next section and subsequently 
used in the following sections of the manual to try out the features of the package. 

 Complete the following form 

Project Title: 
(File Name)  

 

 

 

Start Date:  

 

Goal:  

 

 

 

 

 

Objectives:  

 

 

 

 

 

Specification:  

 

 

 

 

 

Limitations:  
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Project Planning 

This is where the experience and skill of the Project Manager must be used.  At this point 
the project is broken down into a series of tasks and you must ensure you have all the 
necessary information for each task. 
 
The Project Manager must be confident that it will be possible to control the task as 
listed, if there is any doubt then the task should be broken down into a number of smaller 
tasks, each of which will be easier to control. 
 
When defining a task the following is a guide to the information required. 
 

• The Title 

• The Objective of the Task 

• The time required to complete the task. 
(Give an optimistic and pessimistic estimate.) 

• A note of any previous task or tasks that are associated with this task. 

• The immediate subsequent tasks. 

• The resource(s) that are required to complete the task. 

• Any time constraints that apply. 

 
When all the tasks have been specified together with their resources, you have completed 
the major part of the planning of the project. 
 
The next stage is to examine the flow of the tasks and the utilisation of the resources.  It 
may well be that some of the resources are over allocated and these problems must be 
resolved or noted. 
 
At this point it will be possible to Set the Plan, this will become the base line against 
which progress can be measured.  
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Complete the Project Plan 

 Complete the following table  

Number Task Name Duration Predecessors Resources 

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

 



Microsoft Project 2003 
Planning the Project  

© The Mouse Training Company Page 38 
 

Where to Begin with MS Project 

The first step is to enter general information about the project in the Info box.  
 

Starting a New Project 

The Project Info dialog box, illustrated below, records background information and 
allows you to enter scheduling information. The dialog box allows you to specify either 
the project start or finish date. If you enter a start date, the finish date will be 
automatically calculated. If you enter a finish date, the start date will be calculated. Note, 
however, that if you choose to enter a finish date, all tasks will be considered critical 
because they will all be scheduled as late as possible. If you do not enter a project start or 
finish date, Microsoft Project will automatically use the current date as the start date. The 
Project Info dialog box also allows you to specify the project calendar, as shown below. 
 

 
The Project Info Dialog Box 
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Choosing the Statistics button opens the Project Statistics dialog box, below. This dialog 
box displays information on project start and finish dates, duration, work, and cost. It also 
provides comparative statistics you can use to measure the progress of your project. 
 

 
The Project Statistics Dialog Box 

 To start a new project: 
• Choose New from the Standard Toolbar. 

• The Project Information dialog box allows the selection of the 
appropriate information. 

• To view project statistics, choose Statistics. 

• Once you have viewed the necessary information, choose Close. 

 

Project Properties 

You can enter descriptive information about your project in the Properties dialog box. 
This information will help you and others identify the source and purpose of your project. 
The Properties dialog box consists of five tabs, described in the table below.  
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Tab  Function 

General Provides information about the project, including 
project name, file type and size, file location, dates 
and times of file creation, most recent modification, 
and most recent access. 

Summary Provides a description of the project, including title, 
subject, author, company name, manager, category, 
keywords, and comments. 

Statistics Provides information about project use, including 
date created; most recent modification, access, and 
printing; person who last saved it; current revision 
number; total editing time; and summary.  

Contents Contains schedule information, including project start 
and finish dates, duration, total work and cost, and 
percent complete. 

Custom Allows you to enter project properties by which you 
can search and define links to actual values in your 
project. 
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The Calendar 

The Default Working Calendar is used by MS Project to calculate all Timescales and 
Resource costs. It defaults to a working day of 8 hours with the working hours 0800 to 
1200 and 1300 to 1700. 
 
You can create your own calendar with your own particular times. If this is not a standard 
8-hour day you must remember to tell MS Project what the standard day is. Each resource 
you add will be based on the calendar you select when you start your project. 
 
Depending on the nature of your project you may find that the base calendar and standard 
8-hour day is satisfactory. A full day’s work is considered as two shifts⎯one in the 
morning and one in the afternoon. You can use the From and To text boxes in the 
Working Time area to specify up to three shifts. Selecting Default restores selected days 
and working hours to their default settings. 
 
 

 
 

The Change Working Time Dialog Box 
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Resource calendars deal specifically with resources⎯that is, working hours, working 
days, and vacations on an individual basis. Resource calendars are created automatically 
when a resource is added to the pool. Users do not create resource calendars. It is up to 
the user to attach a resource to a specific base calendar. 
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Creating a New Base Calendar 

When creating a new calendar, you have the option of creating a brand new calendar or of 
creating one based on an existing calendar, as indicated below 
 
 

 
 

Creating a New Base Calendar 

 

 Create a new Calendar 
• From the Tools menu, choose Change Working Time. 

• Choose New. 

• In the Name text box, type the new calendar’s name. 

• Select either the Create new base calendar or Make copy of calendar 
option button. 

• Choose OK. 

• If required, select the desired month by clicking the up/down arrow 
on the vertical scroll bar of the calendar. 

• In the calendar, either select specific dates for which you want to 
make a change or select all days of the week by selecting the column 
headings. 

• Specify the changes to be applied to the selected days, i.e., working, 
nonworking, default, or hours. 

• Choose OK 
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Save the New Project File 

Saving a Project 

While you are working on your project, make sure that you save it to disk. It is good 
practice to save your project every fifteen minutes so that, if there is a power outage or 
power surge, you will lose only fifteen minutes of work at the most. 
 
For a new project that you have not yet saved, you can choose either Save or Save As 
from the File menu. However, the Save As dialog box will always appear because the 
project does not have a name. You can give your file a name with as many characters as 
you like, and Microsoft Project will automatically assign the three-character extension 
.MPP. 
 
Once you have named your document, the Save command automatically saves the project 
under its existing filename. The Save As command can still be used if you want to give 
your project a new name, leaving the original file intact.  
 
You can also save (export) your project in formats that other programs can read. For 
example, you can export your project file with an .XLS extension for use in an Excel 
spreadsheet, a .DBF extension for use in a FoxPro or dBase database, or an .MPX 
extension for use in other project management applications. To export a file, in the File 
Save dialog box, select the desired extension from the Save as type drop-down list, type 
the filename, and choose Save. 

 To save an unnamed project: 
 
• From the File menu, choose Save As. 

 OR 

• On the Standard toolbar, click the Save button. 

• If required, select the desired drive and/or folder. 

• If required, select the File name text box. 

• In the File name text box, type the project (file) name. 

• Choose Save. 
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 To save a named project: 
 

• From the File menu, choose Save. 

 OR 

• On the Standard toolbar, click the Save button. 
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Ending a Project Session 

At various intervals, you will need to close a project and work on other ones. 
Alternatively, when you are finished working in Project, you will need to close all your 
projects and exit out of Project altogether. 
 

Closing a Project 

Once you have finished working with an existing project, you will close it. When you do 
this, Project asks whether you need to save the changes. 

 To close a project: 
• From the File menu, choose Close. 

• Choose Yes to save the changes. 

 OR 

• Choose No to close the file without saving the changes. 
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Section Three 

Task Entry and Linking 

After completing this section you will be able to: 

π Understand the various methods of Task 
Entry. 

π Enter Tasks. 

π Link Tasks. 

π Create Summary Tasks. 

π Use the AutoCorrect feature. 
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Entering Tasks 

This is the main activity in setting up a new project.  The tasks which have been identified 
at the Design Stage must be entered. 
 
The system will hold task information in a task database, which we cannot access directly 
but is used by the system whenever we view task data.  This is one of two databases the 
system uses the other being the resource database. 
 
It is important to understand that the system checks the data that it holds and where the 
data does not cross check then the system will generally update the database to make it 
right. It is important to keep an eye on this process; this will be discussed in a later 
section. 
 
As each entry is made the system will update the appropriate data and views to reflect the 
entries. 
 
The order of entry should be in the logical progression but this is not essential as it can be 
changed. 
 
Normal Task entry will be by using the standard Task Sheet. The Gantt View shows the 
Gantt Chart in the right part of the window with the Task Sheet in the left part. 
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The Task Information box/Task Sheet 

 
 

 
The Task sheet is a view of the selected task with information shown in the columns as 
follows: - 
 
ID: The Task Identification number. 

Name: The Name of the Task. 

Duration: The time the Task will take including the time units. 

Start Date: This is the current Scheduled Start date for the Task. 
Not the Planned or Actual Start. 

Finish Date: The Scheduled Finish date. 

Predecessors: The ID numbers for the preceding Tasks that are linked 
to this Task. 

Resources: The names of the resources performing or used in the 
Task. 
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The Task Entry Form 

It is possible to select the Task Entry view to see the Gantt Chart in the upper pane and 
the Task Form in the lower pane. To do this choose View, More Views, Task Entry. 
From the Task Sheet the following entries can be made. 
 
ID: The Task Identification number. 
 
Task Name: The Name of the Task. 
 
Duration: The time the Task will take including the time units. 
 
As the entries are made, the Gantt Chart will automatically be updated to display the 
tasks. 
 
 
If using the Task Form it will be possible to enter and/or view the following. 
 
Name: The name of the task 
 
Duration: The length of time the task will take and the units of time. 
 
Fixed: A check box to specify the start date to be fixed. 
 
Start: The scheduled start date, if this is not entered the system will calculate it 

from the data entered and the relationships defined. 
 
Finish: The scheduled finish date, entered or calculated as above. 
 
% Complete: A measure of the completion of the Task if it has been started. 
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Tables and descriptions 

Resource Table 
 
ID: The identification number of the Resource 

Resource Name: The name of the resource. 

Units The number of units available for the resource. 

Work The amount of work currently assigned to the resource. 

Predecessor Table 

ID The identification number of the Predecessor. 

Predecessor Name: The name of the Predecessor.  If this is not entered the system 
will look it up using the ID number. 

Type: The relationship with the current Task which will be FS, or SS, 
or FF. 

Lag The time delay between the end of the Predecessor the start of 
the Successor. 

It is not necessary to complete all the fields at entry time, as more information is added so 
the system will update the boxes.  It is only necessary to enter the data that has been 
determined in the design stage. 
 

 To enter task descriptions and durations one cell 
at a time: 

 
• In the Task Name column, select the first available cell and type the 

name of the task. 

• Press TAB 

• In the Duration column, type the value of the duration. If the duration 
is anything other than days, type m for minutes, h for hours, or w for 
weeks. 

• Press ENTER 
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• Press LEFT ARROW to return to the Task Name column and repeat 
steps 1 through 4 as required. 

 To enter task descriptions and durations by 
selecting a range: 
 

• Select the first cell (the numbered cell) of the desired range. 

• Drag the mouse through the range of cells you want to include. 

• In the first cell, type the desired information. 

• Press TAB 

• In the Duration column, type the appropriate information. 

• Repeat steps 4 and 5 as required. 

 
Note: Pressing SHIFT+TAB moves to the previous cell without deselecting 
the range. Clicking your mouse inside or outside the range will deselect 
the range. 
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Other Methods of Adding Tasks 

As a general rule Tasks can be added in any view where the tasks are displayed.  The 
most obvious methods in addition to using the normal Task Entry view are as follows: - 

In the Gantt Chart or the Task Sheet 

An additional task can be added at the end of the list using the Insert, New Task 
command. 
 
Where additional information is required to be entered then this can be done by using the 
Task Information form which is opened by simply double-clicking a task in the task list. 
 

Using the Task Information Form 

It is possible to enter additional tasks using this form but it does not have all the possible 
entry points. The details of this form are included in the description of the Task Entry 
View above. 

Using The Network Diagram Chart 

Additional tasks can be placed within the chart by drawing a box and then entering the 
information within the fields.  The relationship can be also be entered graphically by 
pointing to the Predecessor and dragging a line to the Successor. 
 
Where a relationship needs to be removed, a double click on it will display a box which 
has a delete button in it. 
 
Further time will be spent on this view later. 
 

Note: When you try to make a link that is not logical or possible, Project 
will warn you about this (see illustration below). 
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Add Tasks 

The following tasks can be used as a practical in MS Project. 
 

[This column is for 
your info only] 

Task Duration 

Milestone task Course Development 0d 

Summary task Preparation 1d 

Sub tasks Install Software 2h 

   ″    ″   Studies and Specifications 1d 

Summary task Section Development  

Sub tasks Section 1  

   ″    ″ Section 2  

   ″    ″ Section 3  

   ″    ″ Section 4  

   ″    ″ Section 5  

   ″    ″ Section 6  

   ″    ″ Section 7  

   ″    ″ Section 8  

 

• Enter the tasks as above. As you enter them Project will enter 1d as 
the default duration. Change this for Install Software. 

Note: By simply setting the Course Development task to zero days. It is 
given Milestone status. 
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Linking Tasks 

In order that the system is able to display the overall time aspects of the project, each 
Task must be defined in terms of the Tasks on which it is dependent and in turn those 
Tasks that are dependent on it.  It is also possible to define in what way these 
dependencies exist. 
 

Link type Example Description 
Finish-to-
start (FS) 

 The dependent task (B) cannot begin until the task 
that it depends (A) on is complete.  
For example, if you have two tasks, "Dig 
foundation" and "Pour concrete," the "Pour concrete" 
task cannot begin until the "Dig foundation" task is 
complete. 

Start-to-start 
(SS) 

 
 

 

The dependent task (B) cannot begin until the task 
that it depends (A) on begins.  
The dependent task can begin anytime after the task 
that it depends on begins. The SS link type does not 
require that both tasks begin simultaneously. 
For example, if you have two tasks, "Pour concrete" 
and "Level concrete," the "Level concrete" task 
cannot begin until the "Pour concrete" task begins. 

Finish-to-
finish (FF) 

 
 

 

The dependent task (B) cannot be completed until 
the task that it depends on (A) is completed.  
The dependent task can be completed anytime after 
the task that it depends on is completed. The FF link 
type does not require that both tasks be completed 
simultaneously. 
For example, if you have two tasks, "Add wiring" 
and "Inspect electrical," the "Inspect electrical" task 
cannot be completed until the "Add wiring" task is 
completed. 

Start-to-
finish (SF) 

 
 

 

The dependent task (B) cannot be completed until 
the task that it depends on (A) begins.  
The dependent task can be completed anytime after 
the task that it depends on begins. The SF link type 
does not require that the dependent task be 
completed concurrent with the beginning of the task 
on which it depends. 
For example, the roof trusses for your construction 
project are built offsite. Two of the tasks in your 
project are "Truss delivery" and "Assemble roof." 
The "Assemble roof" task cannot be completed until 
the "Truss delivery" task begins. 

 

A 

B 

A 

B 

A 

B 

A 

B 
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We can also fine tune these relationships by specifying Lag or Lead times as required. 
 
Type Example Description 
 
Lead 

 

 
 

Lead time is an overlap between two 
tasks that are linked by a 
dependency. For example, if a task 
can start when its predecessor is half 
finished, you can establish a finish-
to-start dependency and specify a 
lead time of 50% for the successor 
task. You enter the lead time as a 
negative value 

 
 
Lag 

 

 

Lag time is a delay between two 
tasks that are linked by a 
dependency. For example, if there 
must be a two-day delay between the 
finish of one task and the start of 
another, you can establish a finish-to-
start dependency and specify two 
days of lag time for the successor 
task. You enter the lag time as a 
positive value. 
 

 
 
Linking of Tasks can be achieved by making the appropriate entry in any of the task 
views or highlighting the tasks and using the link button on the Tool Bar, or by using the 
Edit, Link Tasks command  
 

Note: You need to highlight the tasks you want to link before trying to link 
them. Use the mouse while holding down the [Ctrl] and/or [Shift] 
button(s) to do this 

 Links are most clearly shown in the Network 
Diagram  

• Enter some of the links by completing the Predecessor ID in the 
lower pane. 

• Add some of the links by selecting them and using the linking button. 

A 

B 

A 

B 
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Defining the Summary Tasks 

Microsoft Project provides the ability to structure the tasks by setting different levels of 
tasks and grouping tasks under a summary task. This can be useful where the project has 
a considerable number of tasks; management can be made easier by only viewing and 
reporting on the summary tasks. 
 

 
 
There are five buttons on the far left of the Formatting Toolbar which can be used on a 
single task or group of highlighted tasks. 
 

 
Promote the selection to the next higher level 

 Demote the selection to the next lower level 

 
Expands a summary task to show its subordinate tasks 

 
Collapse a summary task to hide the subordinate tasks 

 
Hide assignments 

 Show all subtasks, or those of a particular outline 
level. 

 Create Summary Tasks and Link Tasks 
• Select the sub tasks Install Software and Studies and Specification. 

• Indent the tasks to make them sub tasks. 

• While they are still selected link them (chain button or Edit menu). 

• Make Sections 1 to 8 sub tasks and link them. 

• You can also link the summary task Preparation to Module 
development. 
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 Insert Tasks 
If you miss a task from your list you can insert a blank line and type the information. 
 

• Click on Studies and Specifications. 

• Right-click and choose New Task to insert a blank row. 

• Type Backup Installation as the task and set the time to 1h. 

 Add New Tasks 
Having added tasks you can continue adding tasks at the end of your project. 
 

• Move to the line below Section 8 and type Slide Development. 

• Set the Duration to 5d. 

• Outdent the task by clicking on the Outdent button. 

• Link it to Section 8. 

• Save your project as Training Course. 
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• Save with a baseline. 

 Change Duration 
The default duration is 1day. To change this you can simply overtype with the new value. 
 

• Change the durations for 
each Module to 2d. 

• When the Wizard appears 
READ THE 
INFORMATION then 
click on the OK button. 

• Select all the remaining 
tasks. 

• Open the Task information box. 

• Set the duration to 1.5d 

 Multiple Links 
Tasks can be linked to more than one predecessor. 
 

• Select the task Slide Development, hold down the Ctrl key and 
select the task Module 1. 

• Click on the Link Tasks button. 

• When you get a warning, try to figure out why the link is illogical. 
Look at the Gantt chart if it makes it easier to think. 

 Save a Baseline 
• Select Tools, Tracking, Save Baseline from the menus. 

• Click on the Save baseline radio button. 

• Click on the OK button. 



  Microsoft Project 2003 
  Task Entry and Linking 
   

 Page 61 © The Mouse Training Company 
   

 



Microsoft Project 2003 
Task Entry and Linking  

© The Mouse Training Company Page 62 
 

The AutoCorrect Feature 

Microsoft Project 2003 provides the AutoCorrect feature that used to belong only to 
Word. AutoCorrect will assist you in entering and editing tasks. AutoCorrect 
automatically corrects mistyped words and expands abbreviations as you type. Project 
provides an extensive list of predefined typing corrections and abbreviations, and enables 
you to customize the list by adding your own. The AutoCorrect dialog box, as shown 
below, allows you to type an entry (the abbreviation or word that you want to replace) 
and a replacement (the text or graphic you want to use as a replacement). 
 
 

 
 

 To enter an AutoCorrect entry: 
 

• From the Tools menu, choose AutoCorrect. 

• Type the name of the entry in the Replace text box. 

• Type the name of the replacement in the With text box.  

• Choose Add. 

• Choose OK. 
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Section Four 

Resource Management 

At the end of this section you will have: 

π An understanding of the various elements of 
entering and managing resources. 

π Entered resources. 

π Assigned resources to the tasks. 

π Completed the end of the design and 
planning stage. 

π Used the Outlining view 
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Resources 

The management of resources is a major feature of MS Project.  It is possible to see how 
each one is being used and determine the times when they are under or over utilised.  The 
system can adjust the project to eliminate over allocation of a resource.  We can think of 
resource data being stored in a database, which is the partner to the task database.  The 
Microsoft Project system merges the data in the two databases to provide the facilities 
that are available. 
 
There are a number of ways we can view the resources, as the following topics will show. 

Define the Resources 

Complete the following table for the resources used in the Project Plan 
 
ID Name Initials Max 

Units 
Std 

Rate 
Ovt 
Rate 

Cost/Use Accrue 
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When you build a large pool of resources⎯for example, 200 employees⎯the best place 
to enter this information is in the Resource Sheet. If there are only a few resources 
working on the project, however, you might enter them “on the fly” using the Resource 
Assignment dialog box. 
 

Reviewing and Navigating the Resource Sheet 

The Resource Sheet contains an array of required fields for entering resources. A 
Resource Sheet is illustrated below: 
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Enter Resources 

There are two separate stages in adding Resources to be managed by the system.  They 
first must be entered in the Resource Sheet to identify them as being available.  Secondly 
the available resources are associated with the respective tasks. 

Adding Resources to the Resource Sheet 

You add resources to the Resource Sheet in rows. The columns identify the fields. The 
table below summarizes the information that you can store in the Resource Sheet. 
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Field Description 

Resource Name The name given to a resource. It can be the name of an 
individual or a type of group. 

Initials The abbreviated name for the resource. 

Group A resource can be placed in a group, which can be used 
by a filter to show only group members, it is also 
possible to use the group name to view all members of 
the group together. 

Max. Units The percentage (number) of resource units available. 
This is applicable only if using a type of resource. For 
example, you might have three technicians, but you can 
have only one Emma Cheesman. 

Std. Rate The standard cost of the resource per hour, week, or 
month. 

Ovt. Cost The overtime cost of the resource per hour, week, or 
month. 

Cost/Use The cost of the resource every time it is used. 

Accrue At This field identifies when the cost of the resource is 
added to the running total of the project. The options are 
at the "Start", at the "End" or "Prorated" which means 
updated at the end of each time unit as the resource is 
used. 

Base Calendar The base calendar to which you assign the resource. 

Code You can assign an alphanumeric code to each resource. 
The Code field can be used to associate an accounting 
code for use of the resource.  This is an additional 
method of allocating the costs of the project as required. 
and use it for sorting, filtering, and reporting. 

 To add resources to the Resource Sheet: 
 

• From the View menu, choose Resource Sheet. 

• In the Resource Name cell, type the Resource Name. 

• Press TAB 

• Type the necessary information. 

• Repeat steps 3 and 4 until you have entered all the information 
needed for the resource. 

• Press ENTER 

• Press HOME 

• Repeat steps 2 through 7 for each resource. 
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A resource is defined under the following headings:- 
 

ID:  

Name:  

Initials:  

Group:  

Max Units:  

The next items relate to calculating the cost of the resource.  They can be defined by 
setting a cost level for a specific period or a cost for each time the resource is used. 
 

Std. Rate:  

Ovt. Rate:  

Cost/Use:  

Accrue At:  

Code:  

 Practice adding resources 

Mark Woolway M Team Leader 100% £25.00/h £50.00/h £0.00 Prorated Standard 

Emma Cheesman E Contractor 100% £15.00/h £30.00/h £0.00 Prorated Standard 

Julian Cook J Contractor 100% £15.00/h £30.00/h £0.00 Prorated Standard 

Madeleine Adams M Contractor 100% £15.00/h £30.00/h £0.00 Prorated Standard 

Nick Pavey N Contractor 100% £15.00/h £30.00/h £0.00 Prorated Standard 

Richard Buller R Engineer 100% £25.00/h £50.00/h £0.00 Prorated Standard 

Jamie Price J Office 100% £10.00/h £0.00/h £0.00 Prorated Standard 

Binding B Printing 100% £12.00/h £0.00/h £0.00 Prorated Standard 

Copying C Printing 100% £0.00/h £0.00/h £0.00 Prorated Standard 

Technician T Contractor 200% £12.50/h £21.00/h £0.00 Prorated Standard 

 
 

• Select the Resource Sheet from the View menu. 

• Enter the resources from the above table. 
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View Resources 

As with Tasks there are a number of ways that the Resources can be seen in addition to 
viewing the Resource Sheet. 

The Resource Sheet 

Where it is necessary to view all the resources, this is best done in the top part of the 
screen or a single pane view. Selecting Resource Sheet from the View pull down menu 
will show a complete list of the resources required by the tasks. 
 
A valuable feature in this view is that those resources that have been over allocated will 
be shown in a different colour so attention is drawn to the areas that need to be changed. 
 

The Resource Graph 

The best use of this view is in the lower pane with the Gantt Chart at the top. 
 
The Resource Graph will only show one resource at a time and will automatically switch 
to the resource allocated to the task highlighted in the top pane. 
 
One great value of this view is that it shows you when a resource is over-allocated. See 
below, where Emma is over-resourced. 
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Viewing Resource Usage 

Where this view is selected in a single pane or the top pane it will display a list of the 
resources and the amount of work each is allocated on a daily basis. As with the Resource 
Sheet those resources that are over allocated are shown in a different colour and can 
easily be identified. 
 
If this view is selected in the lower pane of a two-pane screen it will only display the 
work for the task that is highlighted in the upper pane. 
 

Viewing the Details of a single Resource 

In any of the above views it is possible to examine the full details of a single resource. 
You place the pointer on the resource and call up the Resource Edit Form by pressing the 
Information button on the tool bar. 
 
Or, simply double-click a resource. 
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Set Resource Calendars 

Where a resource may not be available for all the working hours in the base calendar, it 
can be allocated to a special calendar, which will define the specific working hours for 
that resource only. 
 
Setting the resource calendar is the same as setting the base calendar.  The feature is 
accessed from the Tools menu and the Change Working Time command. 
Having selected this box it will then be necessary to select the resource for which the 
calendar will be used. The respective working and nonworking times can then be entered. 
 
Where a task uses the resource the schedule will be calculated on the basis of when it will 
be available from the resource calendar.  

Allocate Resources 

There are a number of methods of allocating a resource to a task.  
 
The most direct method is to select a view in which a task can be selected and then call up 
the Resource Assignment box using the resource button (The head) on the Tool Bar. 
 

 
 
In the Assign Resources box a list of the resources can be viewed and the required 
selection made. 
 
There are other views in which a resource can be allocated to a task and it does not matter 
which is used, the preference is up to of the user. 
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• Select the Gantt Chart view from the View menu. 

• For each task that needs resources allocated place the pointer on the 
task and call up the Resource Allocation form by pressing the 
Resource Button (the head).  Pull down the list of resources and 
select as appropriate. 

 

 Assign Resources 
Assign the following resources: 
 

Resource Task 
Richard Buller Backup Installation 

Technician Install software 

Emma Cheesman All Modules 

Julian Cook Studies and Specifications 

Nick Pavey Slide Development 
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Editing Resource Information 

Once you enter resource information, you may need to modify it. In the real world, 
employees come and go, and as a result, project managers need to add and delete 
resources. 
 

Editing Data Entered by the User 

You edit resources in the entry box just as you edit fields in the Gantt Chart and the 
Network Diagram Chart. After you make your changes, click the Enter button to accept 
changes, or click the Cancel button to retain the original entry.  

 To edit data entered by the user: 
 

• On the Resource Sheet, select the cell to edit. 

• Press F2 

 OR 

• Click in the entry box. 

• In the entry box, edit the cell contents. 

• Press ENTER 

 

 Edit a Resource 
• As Project Manager, you have managed to reduce the hourly rate of 

Richard Buller. 

• Using the Resource Sheet, double-clicking and using the resource 
Information form, change his hourly rate to £20 and his overtime rate 
to £30. 
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Review Resource Usage 

It is vital that after entering all the tasks and allocating resources the utilisation of each 
resource is checked for over allocation.  Where this occurs it will mean that the project 
timetable will not be met and the completion date will be delayed. 
 
The two views listed below can be used to examine where over allocation has happened. 
It is also possible to check these using the search button from the tool bar. 
 
An over allocation can be cleared by increasing the capacity of the resource i.e. extra 
units, or by moving the tasks.  The latter option is known as resource levelling and the 
system can calculate automatically if required. 
 

Resource Usage 
This view will show a table of all the resources and the respective usage in hours per day.  
Where the resource is over allocated the entry will be in an alternative colour. 
 

Resource Graph 
The Resource Graph is used to display the usage of a single resource and will highlight 
the times the resource is over allocated. 
 
The Graph can be accessed from the View pull down menu and will show the current 
selected resource 
 

Resource Levelling 
Levelling is the process of moving tasks in the time scale to redistribute the use of 
resources where they are over allocated. 
 
This process can be automatic whenever there is a resource over allocation or manually 
from the Tools pull down menu. 
 

 Levelling Resources 
• View the Resource Usage and the Resource Graph and where there 

is an over allocation, consider methods of correcting them. 

Note: All conflicts must be cleared before moving to the next step 
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Inserting and Deleting Resources 

You can add resources either at the end of the Resource Sheet or between existing 
resources. You can also delete unwanted resources from the Resource Sheet. 

 To insert a resource 
• Switch to the Resource Sheet.  

• Select a cell in the row above the one where you want to add a 
resource. 

• Press the [INSERT] key on your keyboard. 

 OR 

• From the Insert menu, choose Insert New Resource. 

 To delete resources 
• Select a cell in the row of each resource you want to delete. 

• Press [DELETE] 

 OR 

• From the Edit menu, choose Delete Resource. 

 

Working with Resources on the Fly 

If the resource you want to add is not part of the resource pool, you can add that resource 
in the Resource Assignment dialog box. At the same time, you can assign the resource to 
tasks. You can add information about the resource later by using the Resource Sheet or 
the Resource Information dialog box. 
 
You can easily add resources while you are in the middle of assigning resources by using 
the Resource Assignment dialog box, and then continue to assign resources. If you realize 
that a resource is missing, you can simply add it at any time. 
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 To add resources on the fly: 
 

• On the Standard toolbar, click the Resource Assignment button. 

• In the Resource Assignment dialog box, select a blank Name cell at 
the end of the resource list. 

• Type the name of the resource. 

• Press ENTER 

Updating Resource Information on the Fly 

Adding resources on the fly does not automatically allow you to update information about 
the resource. You either have to switch to the Resource Sheet to add or update 
information, or you have to open the Resource Information dialog box, as illustrated 
below. All the fields that are available on the Resource Sheet are also available in the 
Resource Information dialog box.  
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 To update resource information on the fly 
 

• On the Standard toolbar, click the Resource Assignment button. 

• In the Resource Assignment dialog box, double-click the resource for 
which you want to add or update information. 

• In the Resource Information dialog box, make the necessary changes. 

• Choose OK. 
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Planned Time Scale 

When all the tasks and resources have been added and any resource problems cleared and 
provided the scheduled dates are acceptable, this marks the completion of the design and 
planning stage. 
 
All of the data entered into the project at this time can be considered as the base line for 
the project to be managed from and measured to.  Microsoft Project will hold this data by 
using the Tracking, Save Baseline command from the Tools menu. 
 
From this point, as the tasks are completed and the data updated it will be possible to 
make comparisons with the plan and determine how late (or early!!!) the completion date 
will be and where the problems are occurring. 
 
This can be seen using the View, More views, Tracking Gantt. The Plan appears as grey 
bars under the Gantt bars. 

Lead Time and Lag Time 

Certain tasks can be started before other tasks are completed. For example Slide 
Development can start any time after Module 1. 
 

 Set lead time on Slide Development: 
• Select the task. 

• Open the Task Information box. 

• Select the Predecessor Tab. 

• Change the type from ‘Finish to Start’ to ‘Finish to Finish’. 

• In the Lag box type .5d. 

• Click on the OK button. 
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The Outlining View (Summary) 

Outlining is used for organization and categorization. Outlining lets you arrange tasks in a 
hierarchical structure and identify project phases. You can use a top-down method for 
outlining, which allows you to enter the major phases first and then add details. You can 
also use a bottom-up method, which allows you to enter all tasks first, and then group 
them in phases once their relationships become clear. With Outlining, you can display 
and/or report only certain levels of detail. 
 
Outlining allows you to organize tasks at up to ten outline levels. Outlining is indicated 
on the Gantt Table by the task’s level of indentation and on the Gantt bar chart by the bar 
shape and pattern. Normal tasks are subordinate tasks, or subtasks, when have a higher-
level task above them. A task that summarizes tasks at the next level down is called a 
summary task. Microsoft automatically determines the summary task values (duration, 
cost, and so on) based on information from the subtasks at the next outline level down 
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Promoting and Demoting Tasks 

You can demote a task to a lower level in the outline by indenting it. If a task is not 
already at the highest outline level, you can promote it to a higher level by outdenting it. 
You can create a summary task by demoting the tasks immediately following it. 

 

 To promote a task: 
 

• Select the task you want to promote. 

• From the Tools menu, choose Outlining, and then choose Outdent. 

 OR 

• On the Formatting toolbar, click the Outdent button. 

 

 To demote a task: 
 

• Select the task you want to demote. 

• From the Tools menu, choose Outlining, and then choose Indent. 

 OR 

• On the Formatting toolbar, click the Indent button. 
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Section Five 

Display Data and Cost Factors 

At the end of this section you will  

π have an understanding of the capabilities of 
Microsoft Project to display project data. 

π filter the project for specific information. 

π be able to examine the cost factors for the 
project. 
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Using Gantt Charts 

Gantt Chart Principals 

The Gantt Chart is a horizontal bar chart that represents each task in the time scale of the 
project.  Each task entered in the project will be shown. 
 
The Gantt Chart can be used to visually keep track of the tasks and also can be used to 
identify important points about each task.  For example those tasks that together control 
the completion date are known as the critical Path and are shown differently to highlight 
that fact. 
 
Gantt Charts can be printed and therefore form the significant part of a regular report 
which shows the current progress, comparison with the original plan, and the new 
projected completion data. 

Changing the split between chart and table 

When the Gantt Chart view or the Task Entry view is selected, the Gantt Chart area has 
part of a table on the left and the bars on the right.  
 
It is possible to move the dividing line between these two areas with the mouse pointer.  
When the pointer is on the dividing line it changes to two vertical lines with left and right 
arrows.  If the left button is held down then the dividing line can be moved to the left or 
right as required. 

Changing Time Scale 

The time scale on the right side of the chart can be changed directly by using the 
View, Zoom command or with the Format, Timescale command. 
 
Where the latter is chosen, the dialog box will provide the ability to change both the 
major and minor time scales and within each of these it will be possible to alter the units, 
the label, the alignment, and the count of the interval between the unit labels. 
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Changing the Palette 

The Palette can be accessed from the Format, Bar command or by double clicking on the 
Gantt Chart. 
 
This dialog box can be used to maximise the information provided by the format of the 
bars on the Gantt Chart.  The appearance of the existing bars can be changed and 
additional bars can be used.  The full use of colour is also possible. 
 
 

 
 
For example it is possible to show the planned, actual and scheduled times for each task.  
 

Editing Tasks 
One method of editing tasks is to change them on the Gantt Chart using the mouse and 
dragging the changes into place. 
 
Positioning the pointer at the beginning of a bar will change the pointer to a % sign and if 
the left button is pressed and the symbol dragged to the right a box will appear showing 
the amount of "percentage complete" that has been added. This information will then be 
updated throughout the system. 
 
If the pointer is placed in the centre of the bar it will change to a four-way arrow pointer.  
If the left button is held down it is then possible to drag the bar to the left or right in time, 
the changing dates options will be shown in a dialog box (see below) and, on clicking 
OK, the files will be updated with the new information. 
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The third possibility is that the duration of the task can be changed by changing the length 
of the bar.  If the pointer is positioned at the right end of the bar it will change into a right 
pointing arrow.  If the left button is held down it is then possible to change the length of 
the bar and the respective change in duration is shown in a box. 

 View the Gantt Chart 
• Select Gantt Chart from the View menu. 

• Place the pointer on the border between chart and table, hold the button 
down and drag the border left or right. 

• From the Format menu, select Timescale. Try changing the major and 
minor scales as view the changes at the bottom of the box. 

• From the View, menu choose Zoom. Try out the various changes that can 
be made to the amount seen. 
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Using Network Diagram Charts 

Network Diagram Chart principals  

The term Network Diagram is derived from Programme Evaluation and Review 
Technique which was invented for the management of Projects by paper based systems. 
This chart is a diagrammatic view of the tasks where the position of the task and the lines 
linking them together represent the detailed steps that comprise the project. It is possible 
to modify the project in the Network Diagram by adding extra tasks or nodes and creating 
the links. Each task on the chart is known as a node and within the node is a selection of 
the data that is relevant to the task. The Nodes can have different boarders which 
represent the task type. 

Using the Format, Box Styles command 

Note: You must have the Network Diagram view active to see Box Styles as 
an option in the Format menu. 

 
Within this command box (shown below) there are many different types of Task, each of 
which can be given a combination of line style and colour to provide visual identification, 
for example the critical tasks can have thick red borders. 
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Changing the contents of a Node  

The Data Template command in the Box Styles dialog allows change to the 
data that the node displays. 

 

It is also possible to set the following:- 
Grid Lines between the five areas - on or off. 

The cross marks that indicate  "In progress" or "Complete" on or off.  

The format for the display of the dates. 

The selection of the size of the Node - Small, Medium or Large. 

Changing the layout of the Chart 

The Format, Layout command gives the ability to select how the 
interconnecting lines between the nodes will be shown. 
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 View the Network Diagram Chart 
• Select Network Diagram Chart from the View menu. 

Note: Make sure the project is open. 

• From the View,  menu, select Zoom and change the size of the Nodes 

• From the Format menu, select Box Styles and examine the different style 
of borders that are available to show different types of tasks. 

• Also check how the contents may be changed using the Boxes Tab. 

• From the Format menu, select Layout and examine the different ways 
the lines can be displayed. 

• You can drag the boxes with the mouse. If you Zoom to 50% or Entire 
Project you will find it easier. 

• Double Click on a Node and examine the options in the dialog box. 

 

Zooming In and Out 

Zooming in can be useful when you want to focus on a particular Network Diagram box 
or group of Network Diagram boxes. Alternatively, zooming out can be helpful when you 
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want to see as much of the project as possible on one screen. The more you zoom out, the 
more clear the paths become and the more unclear the text becomes. 

 To zoom in: 
 
• On the Standard toolbar, click the Zoom In button. 

• Repeat until you reach the desired size. 

 

 To zoom out 
 
• On the Standard toolbar, click the Zoom Out button. 

• Repeat until you reach the desired size. 
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Elements of the Network Diagram 
Chart 

Network Diagram Charts map out the tasks that are required to complete a project. The 
critical path consists of the sequence of tasks in the dark Network Diagram boxes. You 
can’t delay the tasks in the critical path because they have no slack. You can, however, 
delay any of the light boxes because they are not critical. 
 
Like the Gantt Chart, the Network Diagram Chart includes a status bar, an entry bar, and 
the toolbars. In addition, the Network Diagram Chart displays page guidelines so that you 
can control the placement of the Network Diagram boxes on a page-by-page basis. The 
perforated line on the right of the screen represents a page break. 

The Network Diagram Box 

A Network Diagram box consists of five fields, as illustrated below. The Task Name, 
Task ID, Scheduled Start Date, Scheduled Finished Date, and Task Duration are the 
default fields in the Network Diagram box. The Task Name field is white because it is 
currently ready for user input. 
 
 

 

Scheduled 
Finish Date 

Task Duration 

Scheduled 
Start Date 

Task ID 

Task Name 

 
 

The Network Diagram Box and Its Default Fields 
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Navigating the Network Diagram Chart 

The table below summarizes how to move around the Network Diagram Chart with your 
keyboard and with your mouse. 
 
 

Movement Keys Mouse 

To a different Network 
Diagram box 

Arrow keys Click the Network 
Diagram box 

Next field in Network 
Diagram box 

TAB 
or 
ENTER 

Click the field 

Previous field in 
Network Diagram box 

SHIFT+TAB 
or 
SHIFT+ENTER 

Click the field 

Page up or page down PAGE UP 
or 
PAGE DOWN 

On the vertical scroll bar, 
click the gray area above 
or below the scroll box 

Page to the left or right CTRL+PAGE UP 
or 
CTRL+PAGE DOWN 

On the horizontal scroll 
bar, click the gray area on 
the left or right of the 
scroll box to scroll left or 
right in increments 

To upper-left Network 
Diagram box in project 

HOME  

To lower-right Network 
Diagram box in project 

END  

To upper-left Network 
Diagram box on screen
  

CTRL+HOME  

To lower-right Network 
Diagram box on screen 

CTRL+END  

 

Navigating the Network Diagram Chart 

 To navigate a Network Diagram Chart: 
 
• Use the appropriate keystroke or mouse movement. 
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More about Tables 

Much of the data the system holds can be entered and/or viewed in a table format.  The 
system will allow the user to organise these tables so they can be used to maximum 
effect. 
 
The content of the table is also dependent on the area of project management they are 
used for.  There is a difference between tables for Tasks and table for Resources. 
 
The idea of changing a table structure is to make its use more appropriate to the users 
needs in terms of what information the user needs to view.  For a task table there are over 
one hundred possible columns from which the structure can be chosen.  For Resources the 
number of possible columns is approximately thirty. 

Modifying (or editing) an existing Table 

From the menus, select View, Table, More Tables.  The box that will be shown can be 
switched between Task tables or Resource tables. 
 

 
 
 
From whichever aspect is selected, a list of the existing tables will be shown. Select from 
this list the one you want to change/modify. To move to the next screen use the mouse to 
press the Edit button. 
 
The following dialog box (shown on the next page) will show a list of the fields that make 
up the table.  It will be possible to change the width of an existing column, the alignment, 
or the column title.  If no title is shown, the field name is used as the title. 
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If a new field is required then position the pointer at the required position and use the 
mouse to press the Insert [Row/Column] button.  A space will appear and the new field 
can be selected.  To remove a field, point to it and use the mouse to press the Delete 
button. 

 

Creating a New Table 

New Tables can be created by selecting the New button from the More Tables box.  
 
The structure of the table is built up by selecting the fields in the appropriate order. 
 
You can only apply tables to tabular views such as the Resource Sheet, the Task Sheet, or 
the tabular portion of the Gantt Chart. When you choose the Table option, the list of 
available tables will change, depending on the current view. On the View menu, the Table 
option will also list the default table type, separated from the word Table by a colon. 
 

 To apply a table 
 
• Choose a tabular task or resource view. 

• From the View menu, choose Table. 

• From the Table submenu, choose the desired table. 
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Note: If the table you need doesn’t appear in the Table submenu, choose 
More Tables. From the More Tables dialog box, select the desired table, 
and then choose Apply. 
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Applying Filters 

A filter is used to screen out unwanted tasks for a particular view to identify a particular 
aspect of the current state of the project, for example the filter can be set to show the tasks 
that make up the Critical Path. 
 
As with tables there are different filters for tasks and resources and depending on the 
current view the appropriate list of filters will be shown for the selection. 
 
A filter is selected by choosing Project Filtered for and making the appropriate 
selection. 
 

Note: When a filter is no longer required the All Tasks filter should be 
reselected. 

Customising Filters 

Modifying an existing filter or creating a new filter is managed from the Project, 
Filtered for, More Filters command. This will display a dialog box very similar to that 
for define tables (below).  
 

 
 
Select New then the following entries will be required. 
 

Name:  Enter the name of the new filter 

Field Name: Select a field from the entry bar list. 

Test: Select a test from the entry bar list.  

Values: Enter the value that the filter is to check for 
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Op: If there are to be more than one condition then this is the 
operator that will link them together.  A selection may be made 
from the entry bar list. 

 
The following check boxes can also be set:- 

Show Related Summary Tasks 
 This sets the filter to include the Summary tasks where appropriate. 

Show in Menu  
 The filter will be shown in the menu. 
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 Working with Tables and Filters 
• From the View menu, select More Views, Task Sheet. 

 

• From the View, Table menu select and view the different tables 

• From the View, Table, More Tables menu select Define Tables and press 
the Edit button.  Try to make some changes to the table and then view the 
result. 

• From the Tools, Filtered for menu select different filters and see how it 
changes the Table. 

• Examine the Critical filter and try the Edit button to view how the filters 
are set up.  Try making changes to the filter. 
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Examining the Cost Factor 

When all the tasks and their associated resources have been entered, it is possible to view 
the calculated costs of the project and there are several views that can be used. 
The first view is the Task Sheet together with the Cost Table (View, Table, Cost).  
 
  

 
 
 
This view will list all the tasks as originally entered and the associated columns will 
contain the cost data in terms of the Planned cost, the Actual cost and how much has been 
used so far.  
 
This table is very useful in identifying those tasks that are causing the greatest pressure on 
the total cost of the project. 
 
A second way is to chose the Resource Usage then use Format, Details, and choose Cost 
or Cumulative Cost.. 
 

Note: The cost totals will not include any material costs. 
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Changing the Project to Reduce Costs 

To state the obvious, there are a number of ways the costs can be reduced as follows. 
 

• A reduction in the cost per time period of each resource. 

• A reduction in the time a task will take to complete. 

• Where possible a reduction in the use of labour in overtime hours. 

• It may be that where some resources are in slack time and cannot be used, 
a waiting charge is payable.  This can be minimised by re-scheduling to 
minimise this resource slack time. 

MS Project does not have any easy cost reducing commands, where any of the above 
savings can be made the necessary changes to the project must be entered by using the 
editing methods available. 

 

 View the Cost Factors 
• Select View, Resource Usage then choose Format, Details. 
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Section Six 

Printing and Reporting 

At the end of this section you will be able to  

π Print your project file. 

π Create reports from your project. 
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Page Setup 

Before printing it is advisable to check the Page Setup which is accessed from the File 
pull down menu. 
 

 
 

In the dialog box the following tabs can be selected: - 
 

Page: Choose orientation and scaling. 

Margins: Set the margins and borders. 

Header: This box can hold a Header that will be printed on every page. 

Footer This box can hold the footer for every page. 

Legend: This is for printing Gantt and Network Diagram views only 

View: Choose number of columns of task form etc. if appropriate. 

In the Header, Footer, and Legend buttons are available to enter specific information. For 
example the following are available: 
 
These include date, time, page number and number of pages. 
 
The Page size is available under the Printer, Setup option. 
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 Check the Settings for the Gantt Chart 
• Ensure you are viewing the Gantt Chart. 

• Pull down the File menu. 

• Select Page Setup. 

• Select Landscape in the Page box. 

• Check the other settings and change any that are not correct. 

• Press the Print Preview button. 
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Printing Charts, Forms and Sheets 

If the Page Setup has been completed for the views that are to be printed then it is only 
necessary to bring the required view on to the screen and select the print command. The 
settings in Page Setup will align all the necessary settings for the printer and then print 
the view in as many pages as it takes. 
 
There is a Print Preview button in the print dialog box for viewing the printout on 
screen; single or multiple sheets can be shown. It is good practice to check this before 
printing. 
 
Other charts are also fairly easy to produce. 
 

 Print the Gantt Chart 
• When in Preview select Print from the menu. 
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Reports Setup 

MS Project has a number of pre-defined reports based on six principal types which can 
be used directly, changed as required. Alternatively, completely new reports can be 
created. The system is picture driven and simple to use. 
 
Access is from the View, Reports command.  A dialog box appears in which the 
following type of report can be chosen: 
 

 
 

  
 

Overview: Summarizes the most significant project information, 
including numbers of tasks and resources, task and 
schedule status, costs, start and finish dates, and so on. 

Current Activities: Displays information about top-level tasks for the entire 
project. Includes summary tasks and task notes. 

Costs: Shows critical tasks for the entire project. Includes 
summary and successor tasks and task notes. 

Assignments: Shows project milestones. Includes summary tasks 
and task notes. 

Workload: Shows working and nonworking times for 
resources for the entire project duration. 

Custom:  Use an existing report to create a new one. 

 
After selecting one of the above you then choose Select and a second box will appear that 
will have a number of pre-defined options depending on the base of the report. 
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Creating or Editing Reports 

Below is the sub set of reports based on costs. 

 
 
Most of your reports will be available from the pre-selected ones. The Custom choice will 
allow you to design a very specific report if required. Using this feature will hopefully 
now be familiar to you as the principle is not dissimilar to and easier than editing tables 
and filters. 
 
When creating a custom report format the Custom Report box will display 25 options 
which can be used directly or edited according to your needs. 
 

 
 
Clicking New will offer a sub set of possible new reports. 
 

 
 

From this point, most options are choices. 
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When the required settings have been made the new report will be available for printing. 
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What You Can Print 

A Project Overview 

To Print Use 
The number of tasks and resources, the project cost, the total 
amount of work, and the project start and finish dates. 

Project Summary report 
(Overview reports) 

A list of the highest-level summary tasks showing the 
scheduled start and finish dates, the percentage completed 
the cost, and the work. 

Top-Level Tasks report 
(Overview reports) 

A list of project phases (summary tasks) and durations and a 
Gantt bar chart showing summary tasks. 

Gantt Chart view, 
Entry table, and 
Summary tasks filter 

A list of milestone tasks sorted by start date. Milestones report 
(Overview reports) 

Working and non-working time in your schedule. Working Days report 
(Overview reports) 

 
 

Task Information 

To Print Use 
A list of tasks and durations and a Gantt bar chart showing 
tasks, durations, task relationships, and assigned resources. 

Gantt Chart view, 
Entry table, and 
All Tasks filter. 

Scheduled tasks in a calendar format. Calendar view and 
All Tasks filter. 

A list of tasks showing assigned resources and the amount of 
work assigned to each resource per week. 

Task Usage report 
(Workload reports). 

A list of tasks showing start and finish dates and assigned 
resources. 

Task Sheet view, 
Entry table, and 
All Tasks filter. 

A list of critical tasks showing the scheduled start and finish 
dates and the predecessors and successors of each task. 

Critical Tasks report 
(Overview reports). 

A flow chart, or network diagram, showing all tasks and task 
relationships. 

Network Diagram Chart view. 
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Cost information 

To print Use 
A summary of resource costs. Resource Sheet view, 

Cost table and 
All Resources filter. 

Cost information broken down by task and resource over 
time. 

Crosstab report with tasks selected under 
Row, Cost selected under Column, and With 
Resource Assignments selected in Crosstab 
Report dialog box. 

A list of planned and actual resource costs. Resource sheet view and 
Cost table. 

The cost of each task per week, along with the total cost of 
all tasks per week and the total cost of each task. 

Weekly Cash Flow report 
(Cost reports). 

A list of resources whose costs are going to exceed the 
baseline cost. 

Overbudget Resources report 
(Cost reports). 

A graph showing cumulative cost per resource over the life 
of the project. 

Resource Graph view with Cumulative Cost 
chosen from Details submenu on Format 
menu. 

A list of tasks showing whether you are ahead of or behind 
schedule as compared with the actual costs incurred. 

Earned Value report 
(Cost reports). 

A list of tasks showing the budgeted cost of each task and the 
variance between budgeted costs and current costs. 

Budget report 
(Cost reports). 

A list of tasks whose costs are going to exceed the baseline 
cost. 

Overbudget Tasks report 
(Cost reports). 
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Information about resource usage 

To print Use 
A list showing detailed work information for each resource. Resource Sheet view, 

Work Table, and 
All Resources filter. 

A list of resources showing the tasks to which each resource 
is assigned and the amount of work assigned to each resource 
per week. 

Resource report 
(Assignment reports). 

A list of resources showing their assigned tasks, the work 
scheduled for each task, the start and finish dates, and 
additional resource information. 

Who Does What report 
(Assignment reports). 

A list of resources showing their assigned tasks and the daily 
work scheduled for each task. 

Who Does What report 
(Assignment reports). 

A list showing resource use over time, along with the cost, 
the work, and the pay rate of each resource. 

Resource Usage view, 
Summary table, and 
All Resources filter. 

A graph showing the amount of work assigned to each 
resource over time. 

Resource Graph view and 
All Resources filter. 

A resource's tasks, broken down by week. Weekly To-Do List report 
(Assignment reports). 

A list of over allocated resources and the tasks to which they 
are assigned. 

Over allocated Resources report 
(Assignment reports). 
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Information that shows progress 

To print Use 
A list of tasks that are currently in progress showing the 
months in which each task occurs. 

Tasks In Progress report 
(Current Activity reports). 

A list of tasks showing the actual start and finish dates, the 
percentage of each task completed, and the actual and 
remaining task durations. 

Gantt Chart view, 
Tracking table, and 
All Tasks filter. 

A list of tasks starting within a time period that you specify. Tasks Starting Soon report 
(Current Activity reports). 

A list of tasks that haven't started. Unstarted Tasks report 
(Current Activity reports). 

A list of tasks that should have started by the date you 
specify. 

Should Have Started Tasks report 
(Current Activity reports). 

A list of tasks showing the scheduled start and finish dates, 
the baseline start and finish dates, and the difference between 
scheduled and baseline dates. 

Task Sheet view, 
Variance table, and 
All Tasks filter. 

A list of the tasks that have been rescheduled to occur after 
their baseline start dates. 

Slipping Tasks report 
(Current Activity reports). 

A list of completed tasks. Task Sheet view, 
Entry table, and 
Completed Tasks filter. 

A list of completed tasks showing the months in which each 
task occurred 

Completed Tasks report 
(Current Activity reports). 

 

 Check the Reports Available 
• Select View, Reports from the menus. 

• Select one of the reports and press the Select button. 

• Check one of the default reports and press the Select button. A preview is 
shown. 

 Print a Report 
• Select as above. 

• Press the Print Preview button. 
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Reports by Report Type 

To Print Use 
The number of tasks and resources, the project cost, the total 
amount of work, and the project start and finish dates. 

Project Summary report 
(Overview reports) 

A list of the highest-level summary tasks showing the 
scheduled start and finish dates, the percentage completed 
the cost, and the work. 

Top-Level Tasks report 
(Overview reports) 

A list of milestone tasks sorted by start date. Milestones report 
(Overview reports) 

Working and non-working time in your schedule. Working Days report 
(Overview reports) 

A list of critical tasks showing the scheduled start and finish 
dates and the predecessors and successors of each task. 

Critical Tasks report 
(Overview reports). 

 
The cost of each task per week, along with the total cost of 
all tasks per week and the total cost of each task. 

Weekly Cash Flow report 
(Cost reports). 

A list of resources whose costs are going to exceed the 
baseline cost. 

Overbudget Resources report 
(Cost reports). 

A list of tasks showing whether you are ahead of or behind 
schedule as compared with the actual costs incurred. 

Earned Value report 
(Cost reports). 

A list of tasks showing the budgeted cost of each task and the 
variance between budgeted costs and current costs. 

Budget report 
(Cost reports). 

A list of tasks whose costs are going to exceed the baseline 
cost. 

Overbudget Tasks report 
(Cost reports). 

 
A list of project phases (summary tasks) and durations and a 
Gantt bar chart showing summary tasks. 

Gantt Chart view, 
Entry table, and 
Summary tasks filter 

A list of tasks and durations and a Gantt bar chart showing 
tasks, durations, task relationships, and assigned resources. 

Gantt Chart view, 
Entry table, and 
All Tasks filter. 

A list of tasks showing the actual start and finish dates, the 
percentage of each task completed, and the actual and 
remaining task durations. 

Gantt Chart view, 
Tracking table, and 
All Tasks filter. 
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To Print Use 
Scheduled tasks in a calendar format. Calendar view and 

All Tasks filter. 

 
A list of tasks showing start and finish dates and assigned 
resources. 

Task Sheet view, 
Entry table, and 
All Tasks filter. 

A flow chart, or network diagram, showing all tasks and task 
relationships. 

Network Diagram Chart view. 

 
A graph showing cumulative cost per resource over the life 
of the project. 

Resource Graph view with Cumulative Cost 
chosen from Details submenu on Format 
menu. 

 
A list of resources showing the tasks to which each resource 
is assigned and the amount of work assigned to each resource 
per week. 

Resource report 
(Assignment reports). 

A list of resources showing their assigned tasks, the work 
scheduled for each task, the start and finish dates, and 
additional resource information. 

Who Does What report 
(Assignment reports). 

A list of resources showing their assigned tasks and the daily 
work scheduled for each task. 

Who Does What report 
(Assignment reports). 

A resource's tasks, broken down by week. Weekly To-Do List report 
(Assignment reports). 

A list of overallocated resources and the tasks to which they 
are assigned. 

Overallocated Resources report 
(Assignment reports). 

 
A list showing detailed work information for each resource. Resource Sheet view, 

Work Table, and 
All Resources filter. 

 
A list showing resource use over time, along with the cost, 
the work, and the pay rate of each resource. 

Resource Usage view, 
Summary table, and 
All Resources filter. 

A graph showing the amount of work assigned to each 
resource over time. 

Resource Graph view and 
All Resources filter. 
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To Print Use 
A summary of resource costs. Resource Sheet view, 

Cost table and 
All Resources filter. 

 
A list of tasks showing assigned resources and the amount of 
work assigned to each resource per week. 

Task Usage report 
(Workload reports). 

Cost information broken down by task and resource over 
time. 

Crosstab report with tasks selected under 
Row, Cost selected under Column, and With 
Resource Assignments selected in Crosstab 
Report dialog box. 

A list of planned and actual resource costs. Resource sheet view and 
Cost table. 

 
 
A list of tasks that are currently in progress showing the 
months in which each task occurs. 

Tasks In Progress report 
(Current Activity reports). 

A list of tasks starting within a time period that you specify. Tasks Starting Soon report 
(Current Activity reports). 

A list of tasks that haven't started. Unstarted Tasks report 
(Current Activity reports). 

A list of tasks that should have started by the date you 
specify. 

Should Have Started Tasks report 
(Current Activity reports). 

A list of the tasks that have been rescheduled to occur after 
their baseline start dates. 

Slipping Tasks report 
(Current Activity reports). 

A list of completed tasks showing the months in which each 
task occurred 

Completed Tasks report 
(Current Activity reports). 

 
A list of tasks showing the scheduled start and finish dates, 
the baseline start and finish dates, and the difference between 
scheduled and baseline dates. 

Task Sheet view, 
Variance table, and 
All Tasks filter. 

A list of completed tasks. Task Sheet view, 
Entry table, and 
Completed Tasks filter. 
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Section Seven 

Updating the Project 

At the end of this section you will be able to  

π use the various methods available to update 
project data. 
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More on the Task Information Form 

The Task Information Form is divided into six separate pages, each of which can provide 
very useful information to the project manager. 
 
 

 

General 
 Includes Start and Finish dates, %complete and Priority. It also includes boxes for 
Roll-up and Hide Gantt Bar. 

Predecessors 
 Shows any predecessors set and allows you to add others, change the relationship 
and introduce Lag or Lead time. 

Resources 
 You can add or modify resources plus change the task from being resource driven 
to fixed duration. 

Advanced 
 This includes Constraints, Sub-project and WBS codes plus a check box to mark 
as milestone. 

Notes 
 This allows you to add a note. This could be a fuller description of the task, 
allowing you to use a cryptic title. 
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Custom Fields 
 This allows you to add custom fields to the task. 
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Updating Task Data 

As the project progresses it will be necessary to enter updated information to indicate the 
beginning and ending of tasks.  There could also be many reasons why some elements of 
any task may change and to be an effective project management tool the system must be 
updated with these alterations. 
 
MS Project has a number of different ways to change data and the following explain the 
various methods. 
 

Note: The system is dynamic in the sense that if a single element of a task 
is altered that has a bearing on other elements, the changes will be 
calculated and the other elements automatically updated. 

Using a Task View 

In the Task Entry View It is possible to change the value of the % Complete box in the 
Task Form part of the screen and this is the same box that would be seen in the Task 
Form. 
 
The Task Pert does not have an entry space for changing task data except for the ability to 
highlight a task and then access the Task Edit Form. 
 
The Task Sheet is the most user-friendly task view for this purpose provided the Tracking 
table is used.  The default tracking table will have the following columns that can be used 
to directly enter progress data. 
 
Act. Start: The actual date the task started. 

Act. Finish: The actual date the task was completed. 

% Comp.: If the task is started but not finished, the percentage of the work 
completed. 

Act Dur.: The actual number of time periods that have been spent so far. 

Rem. Dur.: The number of time periods left, calculated from the planned or 
scheduled length less the actual duration. 

Act. Cost: The value of calculated from the time periods completed and the cost 
of each resource assigned to the task. 

Act. Work: A measure of the work completed in hours calculated from the actual 
duration and units of each resource. 
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Using the Task Edit Form 

Where the screen is displaying any view in which a task is shown that can be selected 
with the mouse, the Task Edit Form can be accessed by pressing the Form Button on the 
Tool Bar or from the View, More Views... command. 
 
From this form the data relating to the specific task can be changed which includes 
progress data 
 
In addition to the fields in the Task Form the Task Edit Form has the following:- 

 

Dates: 

Current These selections identify which dates are shown in the 
Start and  

Baseline or 
Actual 

Finish boxes. Where progress data is being entered, Actual 
should be selected. 

Start: Actual Start Date and time for the Task. 

Finish: Actual Completion date and time for the Task, if 
completed. 

Constraint: This box can set up a specific constraint on the start or end 
date for the task. There are a fixed number of choices 
which are shown in a list for selection. 

 
The list may contain the following:- 
 

 As Soon as Possible As Late as Possible 

 Finish no earlier than Finish no later than 

 Must finish on   Must start on 

 Start no earlier than Start no later than 

Constraint 
Date: 

This data is specified if any of the last six above are used. 

Subproject: This box can be used to link the project to a Subproject.  
This is where a single task in the principal project is 
managed from a separate project file. 



Microsoft Project 2003 
Updating the Project  

© The Mouse Training Company Page 120 
 

Priority: This box can be used to prioritise different tasks in terms of 
levelling over allocated resources.  The priority relates to 
which tasks can be delayed. The choices are as follows:- 

Do Not Level Highest Very High 
Higher High Medium 
Low Lower Very Low 
Lowest   

 
WBS Code: WBS is Work Breakdown Structure which can be used to 

group tasks together as a an alternative structure to the ID 
numbers.  If nothing is entered, ID number is shown. 

Resources and Predecessors:  These boxes show summary information only. 

Tools, Tracking  
This is a command that provides an update for all or a selection of tasks. 
 
The Choices are : Update Tasks, Update Project, Save Baseline. 
 
Within the form displayed the following are the boxes that appear:- 
 

Name: The Name of the Task. 

Duration: The stated duration of the Task. 

%Complete: The percentage complete if the task has been started. 

Actual Start The actual start date of the task 

Actual Finish If the task is completed, the actual finish date. 

 
The form also displays the Current Start and Finish dates but these cannot be changed 
here. 
 

Note:- Where any of the fields are not completed the system will calculate 
the revised data from the entries made  e.g.  % Completed calculated from 
the Actual time spent entry. 
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Update Tasks 
This will set the instructions to apply to only the highlighted tasks. 

Update Project 
The system will put the current date here but a different date can be entered if 
appropriate. 
 
For those tasks that are before the Update Date select one of the following:- 

Set 0% - 100% Complete. 

For those tasks that should be in progress at the Update Date the % Complete value will 
be set in proportion to the Duration and respective dates. 

Set 0% or 100% Complete. 

If this option is selected then those tasks that have there start date and finish dates before 
the Update Date will have those dates set as the actual start and finish dates. where the 
task should be in progress no percentage complete values will be added. 

 

Reschedule Uncompleted Work to start 
This can be used to change the start date of those tasks that should have started but have 
slipped. the revised start date becomes the Update Date.  
 
You can also choose either Entire Project or Selected Tasks. 

 

Using the Mouse on the Gantt Chart 
As discussed in the previous section it is possible to change the task data using the mouse  
 
Positioning the pointer at the beginning of a bar will change the pointer to a % sign and if 
the left button is pressed and the symbol dragged to the right a box will appear showing 
the amount of "percentage complete" that has been added. This information will then be 
updated throughout the system. 
 
If the pointer is placed in the centre of the bar it will change to a rectangle with left and 
right arrows.  If the left button is held down it is then possible to drag the bar to the left or 
right in time, the changing dates will be show and as before the system will be updated 
with the new information. 
 
The third possibility is that the duration of the task can be changed by changing the length 
of the bar.  If the pointer is positioned at the right end of the bar it will change into a right 
pointing arrow.  If the left button is held down it is then possible to change the length of 
the bar and the respective change in duration is shown in a box. 
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Adding New Tasks 

Using any Table View 

This method will work for any view that is showing a table of tasks irrespective of the 
selected Table format. 
 
Firstly place the pointer on the table at the point the new task is to be added. 
 
Pressing the Insert key or selecting the Insert, Insert Task command will move down 
the tasks and create the space for the new task.  The only element that will not move is the 
ID number, the subsequent tasks will be renumbered to create the space. 
 
With the pointer on the newly created space enter the new task details as appropriate. 
 

Using the Network Diagram Chart 

When viewing the Network Diagram it is also possible to add a new task by manipulating 
the chart with the mouse. 
 
Firstly it may be necessary to move nodes on the chart and this is done by placing the 
pointer on the border of the node where it will change to a circle with four arrows. If the 
left button is held down it will be possible to drag the node to a new position.   
When the button is released the data will move to the new position and the linking arrows 
re drawn automatically to the new positions. 
 
To create a new node place the pointer near the new position, hold down the left button 
and drag out a rectangle.  When the button is released the rectangle will be set to the 
standard node size and can then moved into position as above. 
The links to the new node can be created by placing the pointer in the middle of the 
previous node and dragging a line to the new node.  When the button is releases a new 
arrow showing the link will appear. 
 
A link can be deleted by placing the pointer on it and double clicking the left button. 
(where it will change to a plus sign),  A dialogue box will appear with a number of 
options, one of which is to delete the link. 
 
To enter the details of the new task the node must be highlighted and the Task Edit Form 
can be opened from the button on the tool bar. 
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Entering Task Names and Durations 

You can enter task names and durations from within the Network Diagram box. In 
addition, you can use the Task Information dialog box to enter task names and durations. 

 To enter task names and durations from within 
the Network Diagram box: 
 
• Select the Network Diagram box for which you want to enter information. 

• If it is not already highlighted, select the Task Name field. 

• Type the task name. 

• Press TAB twice. 

• Enter the task duration. 

 

 To enter task names and durations using the Task 
Information dialog box: 
 
• Double-click the Network Diagram box for which you want to enter 

information. 

 OR 

• Select the Network Diagram box for which you want to enter information, 
and on the Standard toolbar, click the Information button. 

• If it is not already selected, select the General tab. 

• Enter the task name and duration. 

• Choose OK. 
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Editing Task Details 

You can edit task fields on the Network Diagram Chart in two ways. You can edit the 
fields from the entry bar, as shown below. As with the Gantt Chart, when you select a 
field, the contents of the field appear in the entry bar box. Click the Enter button to accept 
changes or click the Cancel button to retain the original entry. 
 

 
 
If the Network Diagram box doesn’t display the field you need to edit, you’ll have to 
make your changes in the Task Information dialog box. As in the Gantt Chart, when in 
edit mode, the same rules apply as in a word processor. 
 

 To edit task details from the entry bar: 
• Select the Network Diagram box you want to edit. 

• Press TAB to move to the appropriate field. 

• Press F2 

OR 

• Click in the entry box. 

• In the entry box, edit the cell contents. 

• Press ENTER 
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 To edit task details using the Task Information 
dialog box: 
• Double-click the Network Diagram box for which you want to enter 

information. 

 OR 

• Select the Network Diagram box for which you want to enter information, 
and on the Standard toolbar, click the Task Information button. 

• Select the appropriate tab. 

• Make the necessary changes. 

• Choose OK. 
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Tracking Progress 

Viewing the Gantt Chart 

This is the best visual picture of how the project is progressing.  
  
Examining the use of resources - Viewing the Resource Sheet 
 
Where it is necessary to view all the resources, this is best done in the top part of the 
screen or a single pane view. Selecting Resource Sheet from the View menu will show a 
complete list of the resources required by the tasks. 
 
A valuable feature in this view is that those resources that have been over allocated will 
be shown in a different colour so attention is drawn to the areas that need to be changed. 
 

Viewing the Resource Graph 

The best use of this view is in the lower pane with the Gantt Chart at the top. 
 
The Resource Graph will only show one resource at a time and will automatically switch 
to the resource allocated to the task highlighted in the top pane. 
 
The value of this view is it enables the times that a resource is over allocated to be 
identified easily. 

Viewing Resource Usage 

Where this view is selected in a single pane or the top pane it will display a list of the 
resources and the amount of work each is allocated on a daily basis. As with the Resource 
Sheet those resources that are over allocated are shown in a different colour and can 
easily be identified. 
 
If this view is selected in the lower pane of a two pane screen it will only display the 
work for the task that is highlighted in the upper pane. 
 

Viewing the Details of a Single Resource 

In any of the above views it is possible to examine the full details of a single resource by 
placing the pointer on the resources and calling up the Resource Edit Form by pressing 
the form button on the tool bar. 
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The Gantt Chart and the Critical 
Path 

This is the selection of tasks that together directly effect the completion date of the 
project. 
 
This is because of the way the tasks are linked.   If any of the tasks slip then this will be 
directly reflected in the completion date. 

Modifying the Project to Match Resources 

When a project is first planned, one of the checks that must be made is that the resources 
are not over allocated.  The previous topic showed how the system could be used to locate 
over allocated resources. 
 

To remedy an over allocation there are three alternatives as 
follows: 

• The capacity of the over allocated resource can be increased to eliminate 
the over allocation. 

• The time scale of the tasks involved in the problem can be changed to 
eliminate the over allocation. 

• The amount of resource used can be shortened by using a factor for the 
amount of actual time spent e.g. using [0.5] for half. 

Increasing the Capacity of a Resource. 
This is simple to do in any view in which the available units for a resource can be seen.  
The respective value can be increased as required. 
 
Where the units are not shown the pointer should be placed on the resource and the 
Resource Edit Form selected by pressing the form button in the tool bar.  The dialogue 
box will include the number or units which can be changed. 
 
Re-Scheduling the Tasks to use the available resource capacity. 
 
This is known as Levelling and there is a command to make this happen.  It is in the 
Tools pull down menu and is the Resource Levelling command. 
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Levelling 

This command will display a dialogue box with a number of options: - 
 

Automatic: Select if you always want over allocation to be eliminated 
automatically. 

Manual: Select if Levelling is to be applied by the user. 

Delay only within slack: 
Where this is selected the levelling will only happen within the existing time scale and 
will not put the completion date back. 

 

Automatically Remove Delay: 
This option will automatically remove any existing delay first; otherwise any new delay is 
added. 

 

Order: 
This section provides the selection of the order in which the  levelling will take place. The 
three options are: 
 

• ID Only This will set the levelling to work only by higher ID 
numbers. 

• Standard With this selected the system will consider 
predecessor relationships, slack, dates, and priority 
to decide where the delays will be placed 

• Priority, Standard This option will consider the task priorities first 
before using the standard criteria for levelling. 
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Define an Update Point 

Determine a date approximately a third through the project at which the early tasks can be 
updated. 
 
Complete the following table to define which tasks will be updated and what happened to 
them. 
 
ID Task Name Actual 

Start Date 
Actual 

End Date 
% 

Com 
Actual 

Duration 
Remaining 
Duration 
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Updating the Project 

 Updating the Project 
 

• Select the Task Sheet from the View menu. 

• Update some of the tasks from the data in the table above. 

• Update some of the Tasks by using the Update Task Form. 

 Check the Timescale 
• Select the Gantt Chart from the View menu and make this a full screen 

view. 

• Examine the task time scales and check for problems. 

 Check the Resources 
• Using a full screen, select the Resource Usage view from the View menu 

• Check for over utilised resources. 

• Select Task Entry from the View menu. 

• In the lower pane select Resource Graph from the View menu. 

• By highlighting each task in turn check the use of the respective resource. 

 Making Changes to meet Project Completion 
Criteria 
• Modify a task or tasks to change the completion date of the project and 

check the effects of the changes to cost. 
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Section Eight 

Multiple Projects 

At the end of this section you will have: 

π Set up a common resource 

π Created sub projects. 

π Consolidated projects. 

π Created and managed task relationships 

π Inserted a recurring task. 

π Created a macro. 
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Using Common Resources 

When you have several projects running using a common pool of staff, it is essential that 
you are aware of any conflicts arising due to a staff member being assigned to conflicting 
tasks or unavailable due to other commitments. 
 
MS Project allows you to set up your project so that you share resources and can be 
warned of any such conflicts. 
 
One of the easiest ways is to set up a Staff project and add non-project tasks to this.  Any 
new project created will use the resources of this and show over assignments if these 
occur. 

 Set up a Resource Project 
• Set up a new project entering only items which are not relevant to any of 

your main projects. e.g. Training Course etc. 

• Save as Staff.MPP. 

• Open project CDEV.MPP. 

• Select Tools, resources, Share Resources. 

 

• Select Staff.MPP as the file. 

• Check for any resource over allocations. 
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Adding Sub Projects 

When you have very a large project to manage it may be useful to have some parts split 
into one or more sub projects. These can be inserted into the main project at the 
appropriate point. 
 
This can also be used where some steps in the project are repeated. 
 

 Inserting projects into Projects 
By inserting individual project files into a existing project, you can view, print, or change 
information for the projects you're working with as though they were a single project. 
 

• Open a new or existing project file. 

• On the View Bar, click Gantt Chart  . 

• In the Task Name field, click the row above which you want to insert the 
project. 

Note: You can insert a project at any level of the outline. 

• On the Insert menu, click Project. 

• In the Look in box, click the drive or folder that contains the project file. 

• In the folder list, open the folder that contains the project file you want. 

• If you cannot find the project in the folder list, you can search for it. 
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• Double-click the inserted project as if were a task. Now change the insert 
project options you want. 

 

 
 
 

• If you don't want the inserted project to be linked to its source project, 
clear the Link to Project check box. By default, this option is selected. 

• If you don't want changes to the inserted project to be made in its source 
project, select the Read Only check box. By default, this option is cleared. 

• If you want the inserted project's tasks to be displayed in the consolidated 
project, clear the Hide Subtasks check box. By default, this option is 
selected. You can also choose to hide or show tasks after you've inserted 
the project.  

• To insert two or more projects at the same time, hold down CTRL as you 
click each project. 

 
Note: After you've inserted a project, you can quickly show an inserted 
project's hidden subtasks by clicking the summary task's outline symbol. 
Outline symbols indicate whether a summary task has subtasks displayed    
or does not have subtasks displayed   

 
 

 Create and Add a Sub Project 
• Create a new project based on course development only. 

• Save as CD Sub Project.MPP. 
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• Create a new project based on section 2 except at the point of adding the 
task ‘course development’, insert CD Sub Project.MPP as a sub project. 

Consolidating Projects 

Another way of organising your work, especially if you are monitoring several projects at 
once, is to consolidate them into a single multi-project file. 
 
You can create a consolidated project by inserting copies of individual projects at any 
outline level into a single project file. With a consolidated project, you can view, print, 
and change information for all the projects you're working with (and even those projects 
"owned" by other project managers) as though they were a single project. 
 

Create hierarchies 
 
You can also organize your inserted projects into a hierarchy to better see how the 
different parts fit together. Each project in the hierarchy contains links to the inserted 
projects below it and is connected as an inserted project to the one above it. This way, you 
can isolate and manage smaller chunks of your project with greater efficiency. 
 

Keep information up-to-date 
 
When the copies of individual projects within a consolidated project are linked to their 
original projects, any changes to the information in the consolidated project file are also 
made automatically in the corresponding original files. Likewise, if you change 
information in an original file, the corresponding information is changed in the 
consolidated file automatically. 
 

Make a consolidated project quickly for printing 
 
If you don't want changes to the consolidated project file to affect the source files, you 
can create and save a consolidated project file in which the copies of each project are not 
linked to their source files. You might want to do this, for example, if you're simply 
combining projects to generate a quick report. You can also unlink the source files after 
you create the consolidated project file or consolidate copies of the source files from the 
start. 
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 Consolidate Relevant Projects 
• Open CDEV.MPP and save as CDEV1.MPP, CDEV2.MPP and 

CDEV3.MPP. 

• On the Window menu, click New Window. 

• Hold down CRTL, and then click each of the above projects.. 

• View the consolidated project file. 

 Shortcuts 
• To move to the beginning of a project press CTRL+HOME.  

• To move to the beginning of a project, drag the vertical scroll bar to the 
top of the scrolling region. 

• Use CTRL+HOME to go to task 1. 

 

Consolidating Projects created in earlier versions of 
MS Project 

When you open a Microsoft Project 4.0 or 4.1 consolidated project, the consolidated 
project file is automatically converted to a Microsoft Project 2003 consolidated project 
file using inserted projects. For each individual project included in the consolidated 
project file, Microsoft Project creates an inserted project at the top outline level. The read-
only settings for each inserted project are set according to the settings for the consolidated 
project.  
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Recurring Tasks 

Where a task occurs on a regular basis MS Project allows you to insert it as a Recurring 
Task. 

 Adding a Recurring Task. 
• Select a blank task row. 

• Select Insert, Recurring task. 

 

• Add the task "Project Meeting" and schedule as daily. 

• After the start date include the time 16:30. This will show the meeting 
occurring at 4.30pm. 

• Examine the other options. 

 

 Edit a Recurring Task 
• Double-click the recurring task. 

 Delete a Recurring Task 
• Right-click the task and choose Delete Task. 
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Task Relationships 

Why use task relationships? 

By using different types of task relationships, you can make your project more efficient 
and possibly end the project sooner. 
 
All tasks in Project have one of four relationships to other tasks. By defining these task 
relationships, described in the table below, the project planner can determine how long 
the project will take. Finish-to-start is the default task relationship. 
 
 

Relationship Description Gantt Bar Chart 
Display 

Finish-to-start 
(FS) 

Task starts when its 
predecessor finishes.  

Start-to-start 
(SS) 

Task starts when its 
predecessor starts.  

Finish-to-finish 
(FF) 

Task finishes when its 
predecessor finishes.  

Start-to-finish 
(SF) 

Task finishes when its 
predecessor starts.  

 

Using the Task Information Dialog Box 

Microsoft Project tracks so many fields that you could not possibly display them all on 
the Gantt Chart. You can use the Task Information dialog box to add new tasks; however, 
it is more often used to update information for selected tasks. It is available on most task 
views, including the Gantt Chart, Network Diagram Chart, Task Sheet, and task forms. 
As shown in the illustration on the next page, the Task Information dialog box is broken 
down into five sets of options: General, Predecessors, Resources, Advanced, and Notes. 
These sets of options can be accessed by selecting the appropriate tab. 
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The Task Information Dialog Box 

 

 To use the Task Information dialog box to update 
task information: 
 
• Select the task you want to update. 

• From the Insert menu, choose Task Information. 

 OR 

• On the Standard toolbar, click the Information button.  

 OR 

• If the task is not a summary task, double-click the task. 

• Select the appropriate tab. 

• Make the necessary changes. 

• Choose OK. 

 
As with Gantt Charts, when initially entered, all tasks start on the same date, which is the 
project start date. Defining task relationships allows the project planner to determine how 
long the project will take. On the Network Diagram Chart, you can easily link, unlink, 
and modify tasks. 
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More on Linking Tasks 

If the task relationship is a straightforward finish-to-start relationship, then you can easily 
link tasks by clicking and dragging. You should, however, use the Predecessors options of 
the Task Information dialog box if the relationship is anything other than finish-to-start. 
You should also use the Predecessors options if there is a great distance between the two 
tasks and it does not make sense to click and drag. The Predecessors tab of the Task 
Information dialog box is illustrated below. 
 
 

 
 

 Link tasks by clicking and dragging 
• Point to the center of the predecessor Network Diagram box. 

• Drag to the successor Network Diagram box. 

 Link tasks using the Task Information dialog box 
• Double-click the successor task. 

• Select the Predecessors tab. 

• In the Predecessors area, select the first blank Task Name field. 

• From the entry bar drop-down list, select the task to make a predecessor 
task. 

• Select the Type field for the predecessor task to change. 
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• From the entry bar drop-down list, select a type of relationship. 

• Choose OK. 
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Modifying and Deleting Task 
Relationships 

Once you enter various tasks and establish relationships, you may need to change or even 
delete the tasks and their relationships. The Task Dependency dialog box, shown below, 
is one of the dialog boxes that you can use to modify or delete tasks. You can also use the 
Task Information dialog box to modify or delete task relationships. 
 
 

 
 

 To modify task relationships using the Task 
Dependency dialog box: 
 
• Double-click the link line between the two Network Diagram boxes. 

• Make the necessary changes to the type of relationship and/or the lag 
time. 

• Choose OK. 

 

 To delete task relationships using the Task 
Dependency dialog box: 
 
• Double-click the link line between the two Network Diagram boxes. 

• Choose Delete. 
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 To modify task relationships using the Task 
Information dialog box: 
• Double-click the successor task. 

• Select the Predecessors tab. 

• Select the appropriate cell of the predecessor task. 

• Make the necessary changes. 

• Choose OK. 

 To delete task relationships using the Task 
Information dialog box: 

 
• Double-click the successor task. 

• Select the Predecessors tab. 

• Select the predecessor’s ID. 

• Press DELETE 

• Choose OK. 
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Deleting Tasks 

As well as being able to modify tasks while you make changes to your projects, you can 
also delete tasks. 
 

 To delete a task: 
• Select a task to delete. 

• Press DELETE 

 OR 

• From the Edit menu, choose Delete Task. 
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The Organizer 

The Organizer (sic) is the tabbed dialog box in which you can copy custom views, tables, 
filters, calendars, reports, forms, toolbars, maps, and Microsoft Visual Basic for 
Applications sections (macro containers) to other documents and to other users. 
 
Typically, any changes you make to views, tables, filters, calendars, reports, and forms 
are local; that is, they take place only in the active project file. When opened, a new 
project file shows the original Microsoft Project defaults for those elements, which are 
saved in the global file. However, any changes you make to toolbars, menus, and 
import/export maps are global; that is, the changes are made to the global file and apply to 
all project files on your computer. When you open a new project file, it reflects your 
customized toolbars and menus. When you change format settings (such as bold, italic, 
colour, or bar shape), those settings apply only to the active project file and not to other 
project files on your computer. Changes you make to Visual Basic sections can be either 
global or local, according to your preference. 
 

 
 
 
If you have any customized Microsoft Project settings on your computer it’s a good idea 
to share these elements with other projects using the Organizer. You may want to do this 
if you're standardizing a workgroup or an entire corporation with custom settings. You 
may also want to do this to save time. 
 
Using the Organizer, you can copy customized elements from your global file to another 
project that is open on your computer. You can also use the Organizer to delete any of 
these elements. 
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Create a Custom toolbar button 

This is a relatively easy exercise which rests on the assumption that somewhere there 
does exist a button that launches the Organizer. 

 To Customise the toolbars 
• Select View, Toolbars, Customize. 

• Select the Commands tab. 

• You can now drag buttons to/from the toolbars. 

• When you’ve finished, click Close. 

 Add a button and then edit its appearance 
• Open the Customize dialog box. 

• Click the Commands tab. 

• Locate the Organizer button. 

• Confirm it will do what it’s supposed to by clicking Description. 

 

• Drag the button to a toolbar, between two existing buttons. 

• Right click the mouse on the Organizer toolbar button. 
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• Select Edit Button Image from the pop-up menu. 

• Design your own button using your mouse and the colour palette. 

• Click on OK. 

• In the Command List select Organiser. 

• Enter the word Organiser in the ToolTip: box. 

• Click on OK. 
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